Subpages not clickable on mobile

Hai there, I’m using the Sparkling-theme. On my mobile phone the first page of menu-items is not clickable. Are you familiar with this bug? can it be solved?



Hi Peter,

Sorry to hear of the problem you are having.

Are the menus on our demo site here clickable for you?

Could you please share me your site URL where it’s happening so that i can troubleshoot it?

Also please tell me which browser are you using?

Kind Regards,

Hai Movin,

Since March 10, I did not receive any answer on my question. Are you still working on a solution?
Please let me know . . .


Hi Peter,

You haven’t yet answered my questions that i asked you in my previous reply which will help me to resolve the issue.

Please advise.


I presume you did not receive my e-mail. Here it is again:

Hai Movin,

Thx for responding! I really appreciate that!

The site I’m talking about is:

The main-menu items are clickable in regular browsers on a PC, but not in the ‘mobile-version’.

Please try on a iPhone or other smartphone and click on:


I mean click via the menu off course. Not directly by link :wink:

Hope to hear soon!


Hi Peter,

Please don’t send me any direct email instead please reply on this topic and i will get the email notification of your reply.

I understood what you meant that the top menu item of sub menu is not clickable on mobile browsers which is a default functionality bootstrap framework that this theme uses. you can see it in this example Redirecting…

Actually by default it also doesn’t work on PC browsers but we have developed some custom code to make it work on PC browsers. If we do the same for mobile browsers then users can’t access sub menus because if they click on top level menu item then they will get redirected to that page instead of displaying sub menu therefore we have not implemented this solution for mobile browsers.

I am sure you understand this.

Best Regards,

I got the same problem at my site with Sparkling Theme.
I created the topic before I saw this one:

MY website:

The problem is with menu items that have any sub-items:
– You can’t unroll them in mobile
– The link of main item is only “#” so the link dont go anywhere…

BUT If I go for the demo that you posted then it works fine… without any problems. So its not only bootstrap, but there is something wrong with this theme and mobile users :frowning:
If we dont solve this, then I will have to implement some mobile plugin and I would rather not :frowning:

Screenshot of the problem:

Screeshot of my DEMO:

Ok so I found the problem… and it is actually problem of plugin Bootstrap shortcode Pro… And disabling it doesnt helped because they made it too poorly.

At my website, I use HTTPS. And When I installed that plugin, it tried to load few css fonts over http which failed So I had to edited the paths to HTTPS, then it loaded correctly and everything is fine now… So not your theme but that plugin is the problem. And How I said if you just disable it then it doeasnt help.

Hi @mskarka1,

Awesome great to see you got it found that it’s the plugin problem and not theme issue.

Please advise if you have more questions by creating separate topic.

Have a fantastic day!


I’ve the same problem, but I’ve never installed Bootstrap shortcodes plugin!!! :frowning:


@Luca @peterw This can be due to other plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Also please describe your problem a bit more in detail and make sure you are not facing the issue as i described in the following reply posted previously.

Neither did I . . .