[support request] How to remove the sidebar from a static home page?

I want to use a static home page, because I want to add some customized sections.

I have created a new page, called ‘home’.

It is using template full width (no sidebar), so I’m not sure why a sidebar is still appearing on my home page.

This is what I have under Settings–>Reading :
Front page displays: A static page (select below)
Front page: home
Posts page: news

Am I supposed to create a new template? Why does the one I use still display the sidebar?

Editing my ‘home’ page:
template: default
Layout: Full width OR no sidebar

No matter what settings I pick, my home page displays a side bar.
Any ideas? This behavior seems like a bug for me.

Hi @pablo123,

I hope you are well today and thanks for posting here.

You can try hiding the sidebar from your home page by adding the following CSS code in the Custom CSS option of the latest version of Sparkling theme on the below path.

Admin Area -> Appearance -> Customize -> Sparkling Options -> Other -> Custom CSS

#content .main-content-inner {
    width: 100%;
}div#secondary {
    display: none;

Best Regards,


I appreciate your help, Movin :slight_smile:
This looks like a workaround, and it only hides the sidebar when it is already rendered, right?

Could you explain if this is a problem with the theme? Something that could get patched?

I’ll look at removing the sidebar in PHP, for only my home page.

I have tested it on my test site and it’s working fine for me by configuring the home page options as shown in the attached screenshot.

Please make sure you are using latest version of theme and configure your home page as displayed in the attached screenshot.