Tags aren't working

In theme Newspaper-X tags doesn’t work. The post selection is not correct, always the same post.

The tagcloud also doen’t work. Also always the same post. The demo of Newpaper-X aren’t the tags and tagcloud not working.

Hello there,

I hope you are doing well today.

Just to confirm, have you added tags to your posts, if there are no posts added to the tags then they may not appear.
Could you please provide a link to your website so that I can inspect it?

Best Regards,
Support

I think tags aren’t working too.

>> Could you please provide a link to your website so that I can inspect it?
https://colorlib.com/newspaper-x/tag/money/
https://colorlib.com/newspaper-x/tag/man/
https://colorlib.com/newspaper-x/tag/life/
Those pages are same.

Find line 34 in archive.php
<?php while ( $first_posts->have_posts() ) : $first_posts->the_post(); ?>
I think this line or another line have bugs.

I had fixed.

LINE 34

			<div class="row">
				<?php $count = 1; ?>
				<?php while ( have_posts() ) : the_post(); ?>
					<?php
					$count ++;
					if ( $count > 3 ) {
						continue;
					}
					?>
					<div class="col-md-6">
						<?php
						get_template_part( 'template-parts/content', get_post_format() );
						?>
					</div>
				<?php endwhile; ?>
			</div>

Hi there

Thank you for sharing solution @yuji, have not tried but does it worked for you?

Yes!

Thank you so much :slight_smile: @yuji
You are welcome

At this moment i will close this case since its resolved :slight_smile: