Theme option of "sparkling theme" doesn't show up

I have a problem with theme option of Sparkling theme.
When I click “theme option” in the side bar of admin page,
the screen shows the theme option content only for 1 second,and it disappears immediately.
And then,it’s gonna be like the attached screenshot.
So far,I’ve got no idea to fix this.
I’m using wordpress by Japanese.
Does someone know the solution?
Thank you!


Try to disable completely all plugins that you have installed to see if that works. Since theme options appears for some short period it is very likely that some JavaScript overwrites styles and settings becomes hidden.

If this doesn’t help, try to check your web hosting error log to see what is going on. Since something doesn’t work there must be a reason for that which should be printed as error inside your hosting log.

If both of above suggestions doesn’t help, try to reinstall theme by completely removing it and then installing it again from

Let me know if this helps.


Same issue here :frowning:
I use sparkling on 5 Wp without problems, work great
2 days ago I installed a completely new WP, the theme options worked for a day then I added the plugins and the option pages were gone, they just show up a second and then I only see the share rectacle with Like and support .

So I unabled all plugins, deleted the them on my ftp and installed it again, nothing
I deleted all plugins from the ftp and deleted sparkling, installed sparkling again - nothing changed
Then I tried dazzling and same issue

I deleted WP and reuploaded it and reinstalled sparkling still the same problem

Then I deleted the DB and WP and reinstalled WP again from 0, added ONLY sparkling and nothing else

same issue :frowning:

I dont understand very well logfiles but it says :

[:error] [pid 20819] [client IP HERE] script ‘/home/sitename/public_html/wp-admin/admin-ajax.php’ not found or unable to stat, referer:

I have that admin-ajax.php in the folder

Sat Mar 21 00:07:02.444724 2015] [:error] [pid 19808] [client IP] PHP Warning: require(/home/sitename/public_html/wp-includes/load.php): failed to open stream: No such file or directory in /home/sitename/public_html/wp-settings.php on line 21, referer

maybe thats just an error from when I reinstalled WP and the site was down.

Can I send you the original logfile by email and you can take a look at it please ? I dont want to post it on a public forum

regards Anna

But great them when it works :slight_smile:


I think this is your answer:

admin-ajax.php’ not found or unable to start

I assume that you are using a shared hosting with means that your website resource usage is heavily monitored by your hosting provider. Some plugin that you installed might use admin-ajax.php far too much and triggered security mechanism implemented by your hosting provider. Most likely this file got flagged for unusual activity or as too resource heavy.

You might ask why reinstall didn’t help but it works on other sites on the same hosting?

This file even after reinstall uses the same patch (it is located in the same exact place), so it is still blacklisted by your hosting. It was located here /home/sitename/public_html/wp-admin/admin-ajax.php and it still located at the same place and doesn’t matter how many times you will try to reinstall it.

Make sure to contact your hosting provider and ask if this is the case because Theme Options is not the only thing inside your WordPress dashboard that depends on this functionality and some other things won’t work either.

Let me know if this is the case.

Hello Aigars

Thanks for your answer

No I’m on a dedicated server with only sites I’m running myself
I have like 5-6 other WP with sparkling installed on the same server and they work fine

I dont know what happened on this domain, BUT I found the problem

It dosent work on Chrome (on my mac, I dont have chrome installed on my PC, I tried safari and it worked, also tested FF on a PC and it works)
Weird because the other sparking sites work fine on Chrome (yes I deleted the cache)

Anyway I will ask my my hosting to take a look at that ajax, I might be a problem also

Thanks for a great Theme :slight_smile:


That’s strange.

Maybe try to disable all chrome extensions. For example it is possible to block any element using AdBlock and specify it from domain to domain basis. Or some something like that. it is still worth the shot.

It is a bit more advanced but try to check chat is going on in Chrome dev tools when you reload your website. maybe some script crashed, maybe something is blocked, maybe something far too long to load or conflicts with other scripts.

Also check if file permissions for that file are correct (actually check permission for the entire WordPress installation) as some plugin could have overwritten them, especially security plugins. It can literally be anything as it is only one website and one browser specific.


I tried what Anna says,and it worked in different browser.
Actually,I was using Chrome when I have the problem of theme options.

So,I tried to disable all the Chrome extentions and security protection,but still didn’t work.
Anyways,I can work with theme options now.

Thank you all

Hello Aigars,

I’m also facing same issue with Sparkling theme. “Theme Option” doesn’t even show under “Appearance” menu. Till now, i was using default customizer. I have tried the things you have mentioned above. But still couldn’t figure out whats wrong. I also tried locally on wamp server. Still same. I think there is something missing in theme functions, which hooks the ‘theme options’. I’m attaching admin screenshot. Could you please help?


This thread is marked as resolved and is no longer relevant. Please start your own thread and we will help you from there.

Theme Options are now merged into WordPress theme customizer. All options are still there but are under Appearance >> Customize.