upgrade from v1.9.3 to v2.0.1 breaks site

I’m now getting the following:

Fatal error: Cannot redeclare sparkling_social() (previously declared in /<path>/public_html/wordpress/wp-content/themes/sparkling-child/functions.php:16) in /<path>/public_html/wordpress/wp-content/themes/sparkling/inc/extras.php on line 416

I had a zip of the old version and was able to restore it, but subsequently re-updating to v2.0.1 produced the same results.

Hi @chrisjscott,

Sorry to hear of the problem you are having.

I have tested it on my test site and the latest version of Sparkling theme is working fine for me.

It seems from your shared error message that you are facing this issue due to the custom code added in your child theme.

To confirm it could you please try using Sparkling theme instead of its child theme?

If you confirmed that it’s child theme issue then could you please share it with me so that i can troubleshoot the issue on my test site and help you to resole it.

Best Regards,

Yeah, looks like you’re right - activating the base (v1.9.3) theme and then upgrading doesn’t cause an issue, so it must be w/ my child stuff. I very much appreciate your offering to take a look - child files are attached.


Same happened for me. No difference if I use child theme or standard. No errer message, just a white page with loading icon.
Tested removing plugins, no change

Hi @chrisjscott,

Thank you for sharing your child theme.

I troubleshooted it on my test site and found your shared child theme is still using the old function sparkling_social which were used to display social icons but this function is now replaced by the function sparkling_social_icons so i made this change in your shared child theme and attached the modified child theme to this reply.

For your information, in the latest theme you can create social icons as following :

  1. Create a menu like any other menu in the admin area of your site under Appearance -> Menus .
  2. Use the correct urls in the menu items, so for twitter it must be twitter.com for facebook it must be facebook.com. Otherwise URLs won’t get recognized and you will get squares without icons.
  3. Set theme location for this menu as “Social Links”

Best Regards,

Hi @rodgevbg,

Please check whether you are facing the same issue like @chrisjscott as described above.

If not then to help keep support thread separates could you please create your own thread for your question here https://colorlibsupport.com/c/sparkling/ instead of replying on others thread as it makes the thread messy and hard to read.

If you want to you can also add reference of this thread in your newly created thread.

We would be more than happy to help you on your new thread.



Sorry for the (very) delayed reply, but I wanted to write back and let you know that your fix (the updated social media module in my child theme) worked perfectly. Thanks so much for both the great theme and the even-greater support!


You are most welcome here :slight_smile:

Ugh - sorry to say I’m still having trouble… keeping in mind that when I first reported a problem Sparkling was on v2.0.1 yet I didn’t apply your repair until yesterday (meaning I installed the current v2.2.1)…

I don’t get a PHP error as before, but now the main page isn’t displaying blog posts. When I enter a blog post’s URL the page displays normally (for example: http://blog.chrisjscott.net/2016/01/21/mac-os-x-speed-up-terminal-app-startup/) but neither the main page nor search results show anything.

I guess I need a bit more help - sorry!

Hi @chrisjscott,

I used the shared updated child theme on my test site along with latest version of Sparkling theme and it worked fine for me without any issue.

Have you made any more changes in the shared child theme?

If yes then could you please share it so that i can test it on my test site?



You know, I was thinking earlier today that I should really troubleshoot this myself, as it’s something I should be able to figure out on my own. Throwing it at you as soon as something went wrong is not a good use of your time.

I’ll take the time to troubleshoot it myself and, if I REALLY get stuck, then I’ll ask you to take a look. Until then, please don’t worry about it!

You are always welcome here :slight_smile:

Sure enough. My content.php was completely blank - no idea at all how that happened. Problem solved!

Awesome great to see you got that solved.

Please advise if you have more questions.

Have a fantastic day!