Using Masterslider with Activello

Hello, I have been using the Masterslider plugin with my Activello theme for months and it has worked fine until today when I updated to the latest Activello theme. The slider has disappeared from my home page and I’m not sure why as I haven’t changed any code.

I input the slider on my content-page.php page, using the following code:

if ( is_front_page() ):
echo do_shortcode("[masterslider id=5]");

If you could please let me know how to get this working again, that would be great. Thanks!

Hi @mapes,

I hope you are well today and thank you for your question.

Have you made changes in the theme file or child theme file?

If you make changes in the theme file then you have to make these changes again after theme updation as changes made in the theme files get lost on theme updation.

Best Regards,

Hi Movin

Thanks for your reply.

All the changes I made were to the child theme, not the parent theme. So I’m not sure why it stopped working as the child theme is still activated.


Could you please share me your site URL where it’s happening so that i can troubleshoot it?

Can you please try temporary enabling WP_DEBUG mode? To do this, just go to wp-config.php include this:


You might already have a line for WP_DEBUG, so just make sure it’s set to true.

Let me know what errors if any you are getting when you face this issue.

Hi Movin,

My site is:

I have done a temporary fix for the slider issue by calling the shortcode directly on the front page.

I’m guessing it has something to do with the content-page.php file as I have additional code in this file which is supposed to bring up some words onto the home page as well which is not happening.

In addition, the page which is supposed to display all my blog posts is now blank, except for the words “Older Posts”. It is not pulling my blog excerpts the way it used to. I’m not sure whether the content-page.php file also controls this.

When I ran the WP_DEBUG, this is what came up for the day that I updated to the latest Wordpress 4.8.1 version (and also when I updated the latest Activello theme):

PHP Warning: DOMDocument::loadHTML(): htmlParseEntityRef: expecting ‘;’ in Entity, line: 1 in /home/theraini/public_html/wp-content/plugins/jetpack/json-endpoints/jetpack/class.jetpack-json-api-plugins-endpoint.php on line 214

It seems your child theme uses older theme template file code so please compare the template file code from your child theme with activello theme ans make necessary changes in your child theme template files.

Thanks for your help Movin, I copied the new files over and added my changes and now it all works properly again. Cheers.

You are most welcome here :slight_smile: