Version 2.0.1 still breaks my site

Nice try guys, but Version 2.0.1 still doesn’t cut the mustard, see that attached screenshots to see what happens to one of my sites.

The first one, screenshot 7 is what it looks like before an update, screenshot 6 is what it looks like after the update to V2.0.1

Bam Bam

Hi Bam Bam,

Sorry to hear of the problem you are having.

It seems you are having this problem because the Slider is not configured.

Could you please try configuring the slider from the following path in your admin area.

Admin Area -> Appearance -> Customize -> Dazzling Options -> Slider options

To enable slider tick checkbox “Check if you want to enable slider” on the above path.

Select category from dropdown to use for slider
Now enter number of slides to be used in slider (newest Posts from that category will be used)

Please make sure that you have created categories on your site and assigned it to posts as described on the following page.

https://www.siteground.com/tutorials/wordpress/wordpress_category.htm

Make sure you have Featured Images selected for those Posts as described on the following page.

http://freewptp.com/tutorials/how-to-set-featured-image-or-post-thumbnail-in-wordpress/

Best Regards,
Movin

Movin,

I hope that you didn’t make that last comment simply based on the 2 images.

It is plainly obvious that the slider option is working prior to the update and not afterwards and after checking, it is indeed still enabled.

To release an update to a theme with so many things wrong with it is simply unbelievable.

I have had a look around the site settings and noticed that the Home page template had changed from Full width to default ???

This particular site is something I built as a project that will never see the light of day and I have set up a user for you with Admin rights so you can have a play with it and see if you can find what the problem is.

I have 2 or 3 other active sites using Dazzling and I do not want to update them until all of these problems are completely sorted out.

Your login details are in the next post which I have set as private.

Bam Bam

Login Details

Login Here

Username: Colorlib

Password: c^qPiWaSb1jsJEb3VCZvNlr6

Hi Bam Bam,

I have tested it on my test site and it’s working fine for me using latest version of Dazzling theme by updating it.

I visited your shared site and found you are using custom developed child theme “Big Mango” of Dazzling theme which contains custom code that may be conflicting with this theme update and causing the issue.

To confirm whether this is child theme issue could you please try temporary using the Dazzling theme instead of child theme?

If the Dazzling theme works fine for you then it’s the child theme issue so please share me your child theme code so that i can troubleshoot it.

This can be due to plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

I have had a look around the site settings and noticed that the Home page template had changed from Full width to default ???

The Dazzling theme doesn’t contain any home page template so it seems the template from your custom child theme which is set as home page as shown in the attached screenshot.

Regards,
Movin

Movin,

The slider reappears on the home page when I switch it to the Dazzling theme, but obviously it destroys the site as none of the custom CSS works with it.

At the risk of repeating myself, a theme update should not cause all of these problems, I have never encountered these kinds of problems with a Wordpress theme update in the 8 years I have been building sites with Wordpress.

By the way, you could have tried that yourself, I gave you full Admin rights.

I am using the Child Theme suggested by Colorlib with only minor modifications to it, so why is it a Child Theme problem ???

bam Bam

I forgot to mention that this site as a development/project site does have an enormous amount of plugins, way more than I would normally use, but I deactivated every one of them and re-activated them one at a time and it had no effect on the silder not working at all on the home page.

Something else I have not yet mentioned is that the Full width template seems to work as it should, LINK HERE, but the pages using a sidebar look nothing like they should, Link Here they have a dark green background instead of the white background they should have.

Again it is obviously something to do with the Child theme, but why should an update upset the apple cart like that, when I am using the Child theme suggested by Colorlib, which I might add is vastly different to any child theme I have used in the past.

Bam Bam

Hi Bam Bam,

We test our theme carefully before releasing it to use for public but some issues are only reproduced on the user website in specific situation. We resolve these issues ASAP when we could reproduce it.

All theme options are now moved to WordPress customizer that you can find in the admin area under Appearance >> Customize. This is a major change and is made due to wordpress.org recommendation. I think this may be causing your child theme functionality.

As requested could you please share me your child theme so that i can troubleshoot the issue on my test site?

Regards,
Movin

Movin,

I have already given you full admin rights which means you have access to the Child theme files via the editor.

bam Bam

Hi Bam Bam,

I need your child theme on my local testing environment to troubleshoot it as i have some restrictions to do it using theme editor.

I am sure you understand this.

Regards,
Movin

Movin,

Apologies for the slow reply, I have been away on holiday for Christmas and I thought I would give both of us a break from this.

This issue has now taken on some more urgency, as I have it on a couple of live sites and I have just discovered that there is an issue that I believe is possibly theme related when viewing the sites in Firefox and that is the text fields in Contact Forms cannot be filled in, it is fine in Chrome and Edge.

You can see that problem HERE

Here is the code from the style.css minus my custom css that it contains, from memory it was something that Colorlib supplied previously and I have almost exactly the same thing on the sites I have used Dazzling on.

/*
Theme Name: Big Mango
Theme URI: https://colorlib.com/wp/themes/dazzling
Author: Colorlib
Author URI: https://colorlib.com/
Description: Dazzling is a clean minimal and responsive WordPress theme well suited for travel, health, business, finance, design, art, personal and any other creative websites and blogs. Developed using Bootstrap 3 that makes it mobile and tablets friendly. Theme comes with full-screen slider, social icon integration, author bio, popular posts widget and improved category widget. Sparkling incorporates latest web standards such as HTML5 and CSS3 and is SEO friendly thanks to its clean structure and codebase. It has dozens of Theme Options to change theme layout, colors, fonts, slider settings and much more. Theme is also translation and multilingual ready and is available in Spanish. Sparkling is a free WordPress theme with premium functionality and design.
Version: 1.0.0
Template: dazzling
License: GNU General Public License v2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html
Text Domain: dazzling
Domain Path: /languages/
Tags: green, light, white, gray, black, one-column, two-columns, right-sidebar, fluid-layout, responsive-layout, photoblogging, left-sidebar, translation-ready, custom-background, custom-colors, custom-menu, featured-images, full-width-template, post-formats, theme-options, threaded-comments

This theme, like WordPress, is licensed under the GPL.

Dazzling is based on Underscores http://underscores.me/, (C) 2012-2015 Automattic, Inc.

*/

/* Your custom styles should go right after this line */

/* Theme Options (CSS) */

The full version with all of the custom css is also attached (providing that worked and you can download it)

Wishing you a Happy and Prosperous New Year
Bam Bam

Hi Bam Bam,

Happy New Year… !!!

The style.css file that you tried to attach is not uploaded properly and displaying the error for me “style.css: Sorry, this file type is not permitted for security reasons.”. You should have zipped the file and then upload it.

This issue has now taken on some more urgency, as I have it on a couple of live sites and I have just discovered that there is an issue that I believe is possibly theme related when viewing the sites in Firefox and that is the text fields in Contact Forms cannot be filled in, it is fine in Chrome and Edge.

I could confirm the issue on Firefox browser on your site and it seems the issue of the following JavaScript code added in your site.

To resolve the issue could you please try removing the following js code from your site?

<script language=JavaScript>
  var message="!!YOU CANNOT COPY ANY TEXT OR IMAGE FROM THIS SITE!";
  function clickIE4()
  {
    if (event.button==2)
    {
      alert(message);
      return false;
    }
  }
  function clickNS4(e)
  {
    if (document.layers||document.getElementById&&!document.all)
    {
      if (e.which==2||e.which==3)
      {
        alert(message);
        return false;
      }
    }
  }

  if (document.layers)
  {
    document.captureEvents(Event.MOUSEDOWN);
    document.onmousedown=clickNS4;
  }
  else if (document.all&&!document.getElementById)
  {
    document.onmousedown=clickIE4;
  }
  document.oncontextmenu=new Function("alert(message);return false")
  
  
  function disableselect(e){
		return false
		}
		
		function reEnable(){
		return true
		}
		
		document.onselectstart=new Function ("return false")
		
		if (window.sidebar){
		document.onmousedown=disableselect
		document.onclick=reEnable
		}
</script>

If the js code is added by plugin then try deactivating that conflicting plugin.

Regards,
Movin

Movin,

Thanks for the advice on what is causing the Firefox issue, I didn’t add that code, but the site owner had someone else do something for him that was a bit outside of my ability and I suspect he added it.

I have attached the zipped up style.css file.

Bam Bam

I didn’t see any major issue in the style.ss file that you have shared. When i disable javascript on my firefox browser then it’s working fine so it seems the javascript code on your site is causing this issue. Please try removing it.

Which issue, the Firefox problem or the theme update breaking the site ???

The Firefox thing is a side issue, the style.css is for another site using Dazzling and is still the major problem

Hi Bam Bam,

I was talking about in my previous reply regarding firefox specific issue that you have mentioned previously.

Regarding your child theme issue as requested could you please share me your whole child theme directory in zip format and not just style.css file?

Regards,
Movin

Movin,

My apologies, attached is the entire child theme for the live site with the Firefox issues, it is the one with the most importance that we get over this problem, hopefully we can apply the fix for this to the other couple of sites I use Dazzling on.

Bam Bam

Hi Bam Bam,

Thank you for sharing your child theme.

I could confirm the issue on my test site using your shared child theme and resolved the issues by modifying child theme files header.php and footer.php

I have attached the updated modified child theme to this reply so could you please try using it.

Best Regards,
Movin

Ok thanks, I shall take a look.

Bam Bam

Movin,

Thank you your patience with this issue, the files you sent me fixed it finally.

Kindest Regards
Bam Bam