Academics template - Mobile burger menu items not clickable

I’m having this exact same issue as posted on the forum link below

I found your academics template which I have purchased a user license for. I have found an issue with the academics template.

When testing on a mobile device, the menu button (burger menu) does appear to work (be clickable) when I click on any of the burger menu items (hyperlinks), the links do not work on any of my mobile devices, be it Android or iOS. Please note that I’m having the exact same issue if I use any desktop browser and I make it horizontally thin so that the burger menu appears, the burger menu items (hyperlinks) are visible but do not work. Not only have I tried this in iis and xampp on multiple desktop development machines (Windows 8, 10 and 11), but I’ve also uploaded your template directly onto my online http hosted server via ftp, the exact same burger menu issue is happening online where I have other website hosted.

Clicking on any of the burger menu items via my mobile devices does absolutely nothing once the mobile burher menu appears, but the menu items hyperlink does work on normal desktop browsers if the browser is in full screen (maximised).

Please note:
If I remove ‘jquery.sticky.js’ or ‘js-sticky-header’ from any of the html pages, the top of the template obviously messes up but the burger menu hyperlinks start to work on mobile devices.

If I just unzip your template and upload the filed directly onto my online sharef server via ftp, the burger menu items do not work, but the basic hyperlinks do work on full screen (maximised) using desktop browsers in full screen (maximised).

The screenshot below shows that nothing happens when I click on any of the burger menu items, the hyperlinks are not changing the url.

Thank you.

Hi Peter

Thanks for details, any chance to see thi problem live? can you please provide url of the page?


I’ve downloaded your website template in the paid email that colorlib sent me. I unzipped and uploaded the template to a temporary folder on a site that one day I will update with another one of your templates, which I’ll happily pay for again.

As you can clearly see on a mobile or any desktop browsers (when made horizontally thinner so the burger menu appears), the hyperlinks in the burger menu do not work. I’ve uploaded your template website directly onto a couple of online servers that I have access to both Windows and Linux, and the results are exactly the same. When the burger menu appears, the hyperlinks do not jump to the page and the menu does not close.

I’ve put your template directly into a sub folder, but it does the exact same thing in a root folder too.

Please advise. I’ve spent a long time creating a website for someone and when I showed it to them on their own URL, they were annoying to see that the menu didn’t work on their mobile devices.

Please note that I’ve also tested your unmodified template on my development machines running both iis and xampp, the burger menu hyperlinks just do not work.

If I comment out the following line at the bottom of the template (for example on index.html) the top of the temple will completely mess up, but the burger menu hyperlinks will start to work.

The line that I comment out is as follows. The template messes up but the burger menu hyperlinks start to work.

Thank you.

Actually you can try the following.
Download and unzip your own template into a folder on your desktop, go into the folder and double click on index.html. Make the browser thinner so the burger menu appears, now click on any of the hyperlinks.

Hi Peter

Thanks for detailed instruction, I just tried it and I have a working hamburger menu: Screenshot by Lightshot
is this resolved or I’m missing something?


What can I say except that your own template is not working correctly well this particular menu on this particular template isn’t anyway.

We’ll in that case I would like to get a refund. Please note that I’ve ripped ripped the menu code out including the .js and .css files and placed them in a blank html page, yes it worked perfectly fine. I then did the exact same thing on another client’s working website. In both cases every works perfectly fine, but not in this template.

When I just unzip your your template on a Windows 8, 10 or 11 desktop and run it, the hamburger hyperlinks do not work. They do not work on my dell or windows servers online either. I’ve even tried it in xampp, hyperlinks are not working, exactly like in the previous post by another user. I can’t explain or say much more than I already have, sorry about that.

If you can’t get this matter resolved, then I would like to request a full refund as this is pretty simple to explain and it’s not working for me under any circumstances. I’ve not tried it on my MacBook air or MacBook Pro but I can’t see it work.

Actually thinking about, I would like you to send me the exact files that you are using in your screen. If to want to you can just share them with me via Dropbox.

I’m not sure how you’re getting it to work, but it’s not working for me.

If you want me to provide proof because you clearly don’t believe me, I can create a video and upload it to YouTube for you of the whole process…

Should I take it that you’re now ignoring me?

Hi there

I apologize for the delay. I understand your frustration and the situation you’re facing. I tested it, and unfortunately, I also encountered some issues, which is unfortunate. In such cases, we typically report it as a bug and work on fixing and releasing an updated template, however, I cant provide any ETA.

Let me know what is your decision.


I would like a working template. I’ve worked extremely hard modifying the template and adding the website information as needed, so it would be nice if the hamburger menu would work as expected.

Also the scrolling carousel images at the top of the page do not automatically resize when viewing the website on a mobile device. Basically on a desktop browser you can see the full images in the scrolling carousel, but on a mobile device all you get to see is a bit of the left hand side of the images. Basically the scrolling carousel images are not showing in full on mobile devices, I e tested it out on around 7 or 8 phones as I’m a mobile app developer thus I own multiple devices for test purposes.

Thank you…

Hi @Da_Man

I completely understand your situation, and I apologize for any inconvenience this may have caused.
Typically, templates don’t encounter such issues, so I appreciate your understanding.

Fortunately, I can assist you with fixing the carousel images. Just add the following CSS code at the bottom of your CSS file, and it should resolve the problem:

.intro-section {
    background-position: center center;

Kind regards

Thank you for your reply.

I was looking for the whole carousel to resize to match the screen size be it desktop or mobile, thus still showing the whole image and not just part of the image. The solution you provided is an improvement though. If at some point that could be incorporated correctly, it would be greatly appreciated.

The hamburger menu items issue is a big issue though. I’ve had to adapt and use a free responsive on your Academics template which is not an ideal solution. The menu is not as nice as the original so that does need looking at at fixing at some point.


Hey @Da_Man

I understand, if you still want to somehow correct the images in the carousel I will help you.

My apologies about that, but you know what? if you don’t like styling I can help with custom CSS, jet let me know how exactly you want it and I will generate custom CSS for you.

Have a good weekend,


No it’s okay, I’ve now edited the images so that the important part of the image is now in the centre of the jpg, it now looks better on mobile devices. Not perfect but better so that’s okay with me.

Thank you.

Thanks for understanding @Da_Man

If there is anything else feel free to start a new ticket :slight_smile:

Have a good week ahead.


I was wondering is there any news on updating this template. It would be nice to use the original menu/hamburger menu working with this template and not the menu that I somehow put together.

Hi there

My apologies @Da_Man still the same, :frowning: I know how frustrating this can be