Child theme breaks all but the home page

Dear support

in all these years I’ve been using Sparkilng them, I haven’t been able to use a child theme correctly. Recently again I tried yet another plug in and also the child theme it creates will break the style in all but the home page. I mean the main/home page is good, but when I click to some other sub-page on my menu it all falls apart. I have the Sparkling 2.4.4 version and PHP seems to be 7.3.6.

So could you please make me child theme that works if I give you my website link? Some years ago the support made child themes to some individual users. Like here when someone had the same issue with Shapely:

Thank you

hey there

Please provide link to the affected page and let me know steps how to replicate your problem

By the way, may I know why you child theme? do you have any modifications inside?

Hi, thanks for the reply. Is it possible to make a private reply like it was before if I don’t want my site domain to be public here?

I managed to find an old child theme I had somewhere and now when I tried it, it works, more or less. Strange. Still there is the problem of two tier drop-down menus on mobile mode. The sub menu under the countries does not open. The structure is as follows; COUNTRIES>“name of a country”>“place”

That “place” sub category doesn’t drop down. So I’m in the same point as before updating the parent theme. This was the issue I thought was somehow related to my outdated theme. But as it seems things didn’t change:/ Any ideas?

Hey there

Ok, that sound good :slight_smile:
Sorry but, there is no such opinion but you may delete url after investigation of the problem
I still need it to review your problem with he menue

So how is it? Did you find solution?

Hey there

Sorry for the delay, @kauno
This is what I have right now: menu is working just fine for me, is this problem already resolved?

Hi, thanks for getting back to this, but that is not what I meant. Try the countries menu and the submenu like I advised. Countries->India>“name of the clinic”. It won’t open up.

Hey there

Are you talking about this?
Which devise you are using?

Hi, it seems to work and now when I tried with another browser that allows me to zoom in it works. With Android Firefox it did not work as the arrow buttons are too small. Maybe you could make the arrows and the touch area bigger in the next update?

Please could you delete those screenshots so they don’t remain here? I will remove my link. And we can mark this as resolved.

Hey there

I just removed screenshot

Well, that’s possible but so fare this is only one report of this issue and honestly I cant make a bug report from this problem, if you still experience any problem with this I can help with custom css to increase arrows

Thank you. There is one screenshot still up. And yes, if you could try the custom CSS that would be great!

Sorry, I just removed it :slight_smile:

Thanks. How is it with the custom CSS? Any hope in getting it anytime soon?

Let’s try but I need a link to your website again :slight_smile:

Try this css code to increase caret size:

.caret {
border-top: 10px dashed;
border-right: 6px solid #0000;
border-left: 6px solid #0000;

Thanks, that is great. But it does not completely solve the issue with Firefox, however, after some playing around I was able to open the submenus. Maybe it’s the issue with the browser and my Jolla phone or the touch area under the buttons is the culprit. But at least now the buttons are visually bigger. Maybe this is all you can do for now. Thank you again.

Thank you for understanding @kauno :slight_smile:

Have a nice week and let me know if you need anything else