Contact Us section bug


When i try to edit the title or addres/customer support title, e.g. changin “Contact Us” to “Contact”, the new entry wont be added to my website. If i save it, the website just shows the default “Contact Us” / “Addres” / “Customer Support” titles.

Hi Support team,

I also have ‘Contact us’ issue. Can you please share with me the solution. you can see in my screenshot that contact us title on first page is missing. And also Adrees and Customer support title.

Thank you so much in advance. looking forward for the solution.

Nivesh Gandhi

Bump. Same here. Please help?

Hi Guys, I had the same problem and solved it as follows:

First I have copied the ‘front-page-contact-us.php’ to my child theme (or you can modify it directly in the original theme).

Then I modified the following lines:

Change line:
<h3><?php echo do_shortcode(wp_kses_post( $general_title )); ?></h3>
<h3><?php echo __( ‘[:es]Contacto[:de]Kontakt[:en]Contact[:]’ ); ?></h3>

Change line:
<?php echo illdy_sanitize_html( $general_address_title ); ?>
<?php echo __( ‘[:es]Dirección[:de]Adresse[:en]Address[:]’ ); ?>

Change line:
<?php echo illdy_sanitize_html( $customer_support_title ); ?>
<?php echo __( ‘[:es]Información Clientes[:de]Kundenkontakt[:en]Customer Support[:]’ ); ?>

Change line:
<span class=“box-right-row” data-customizer=“contact-us-phone”><?php _e( ‘Phone:’, ‘illdy’ ); ?> <?php echo illdy_sanitize_html( $phone ); ?></span>
<span class=“box-right-row” data-customizer=“contact-us-phone”><?php _e( ‘[:es]Cel.:[:de]Tel.:[:en]Phone:[:]’, ‘illdy’ ); ?> <?php echo illdy_sanitize_html( $phone ); ?></span>

The rest of the fields worked for me so no need to change anything. Note that I use the Qtranslate-X Plugin so I had to use all my 3 languages. If you do not need that write only your desired text between the ’ ’ .

Hope that helps a little bit!



It worked! Thanks!

Hello there,

I hope you are all doing well today.

I apologize for the late response and thank you, @interklaus for providing the solution for the problem.

Best Regards,

Hey, i have the same problem and your solution @interklaus only works when I´m logged in. It doesn´t work on all other devices where I´m not logged in into my wordpress account… Can you help me?