Customise > Additional CSS not working

Hi, this initially worked when I first installed the theme, but recently I’ve only been getting the message to ‘wait a few seconds and try again’ error message, but the CSS doesn’t publish.

I’ve tried deactivating all the plugins and trying, but I get the same issue. Can I get some help to find out the problem?

Good evening Dan

Can you show me a screenshot of the problem? also, please change WordPress theme temporary and try again, if it is not working with other themes then we need to deal with the WordPress and not with the theme, let me know results

Colorlib Support Team

Hi Noda,

Thanks for your message. Yes, I temporarily switched to the WP 2019 theme and the ‘Additional CSS’ worked fine on that theme. See screenshots of error and the working 2019 theme attached.


Ok, let me check it, please use this plugin to create temporary access for us, its automatic login link and does not requires sharing your admin details. here is How To guide. at the and don’t forget about  “Set as private reply” at the bottom of the message box 

Hi Noda, many thanks for this. Here’s the temp login Let me know if it works ok!

Hi Noda, I’m afraid that the shortcodes don’t seem to be working properly either. I tried with the Modula plugin shortcode on page but it didn’t work. I then tried with another gallery plugin and again it didn’t show up on the page.

Good evening

checking your problem right now and i can say for sure css codes are working in custom css box, also, what i wanted to mention, its different than your screenshot, there a re lot of css codes added and they are working as well, are you sharing proper site?

The problem is when I try to change the CSS it does not publish and gives me the error message that I showed in the screenshot.

Good morning

Yes, i see and it was different from the screenshot and that’s why I asked
Ok, now regarding the problem, you have a bunch of errors on the customizer page, starting from 404, 406 errors and including mixed content loading warning, can you tell me what happened to this site? have you changed url? or anything like that?
such a problem might be the server related but please check is your plugins are not doing this, deactivate all third party plugins and try again your problem, most probably this I conflict with third-party plugins.
Once you deactivate all plugins please check your problem again, if the problem is gone then this means it was a plugin conflict. Now, start activating plugins one by one and same time repeat your problem until your problem appears again, now you know which plugin was in conflict

Hi Noda,

If you see my very first message I stated that I had deactivated the plugins and the problem was still there. I also said that I tried another theme and the Additional CSS worked.

The only thing that has happened recently is that I switched from http:// to the secure https:// domain name.

Can you help?

Hello Dan

“The only thing that has happened recently is that I switched from http:// to the secure https:// domain name” - Well, you should mention this before :slight_smile: this is the problem, can you tell me how you did this? if you only switched it from WordPress settings this might be not work

P.s. such problems are not theme related, you have this problem with this theme right now because when you switched to https you have this theme activated

Oh no. Do you know if it’s fixable? To be honest I don’t remember when it switched to https//: I only realised after the hosting changed the php version, perhaps it also happened then. But I also installed the Really Simple SSL plugin. Sorry it’s not clear!

Good evening

Right now customizer and some other functions of your website is not working, my suggestion is to take back your changes (witch to http) again and then lets plan how we can make the planned move to https, also, please note you must have valid ssl certificate for your website,

Hi Noda,

I deactivated the Simple SSL plugin and also contacted my hosting. They said they had to look into how to revert it back to http//:. They provide a free SSL certificate with their hosting. Are you sure that’s the problem though? I did a similar thing with another WordPress site and there were no issues.

Dan, please enable the link for me again

Sorry, I’ve reactivated the plugin so hopefully works now! Sorry for the inconvenience.

Good evening

OK, the problem is still not fixed but now i have the error code and we know the cause, please get in touch with your hosting support and let them know that you are getting this error:

POST 406 (Not Acceptable)

in dev tools when you saving any changes in the customizer, this error message is server-side error and your hosting support should be able to fix it, its related to mod security mode

Many thanks Noda. I really appreciate it. They’ve passed it onto the technical team apparently, so hopefully they’ll fix it soon!

Ok Dan,

let me know the results I’m also interested :slight_smile:

Hi Noda.

Thanks so much for that. :slight_smile: You are right! After they fixed that I seem to be able to make the changes in CSS without any trouble. So glad you found that error, as my hosting support has been pretty useless!

I also have the modular gallery plugin and another shortcode which aren’t working on It’s a problem with the shortcodes as I also had an issue on the contact page, so I had to remove that form shortcode. Any idea what that may be? I asked the hosting support but they haven’t got back to me yet.

Thanks so much!