Dazzling Child Theme navigation - dropdown menu items have stopped working


I hope you can help us out! Sometime over the last couple of weeks, the dropdown menu items on our main nav have stopped working. You can over over them and you’ll see “#” as the URL even though a page is specified in the menu. And mousing over gets you no dropdowns.

(initially the dropdowns were under About Us and Contact Us, but we temporarily removed the submenu for Contact Us because it was preventing access to the contact form.)

We’re running WP 5.1.1 on PHP 7.3 with everything updated including Dazzling.

So far i’ve tried:

  1. Rolling back PHP to 5.6
  2. disabling all plugins
  3. Switched to the parent theme to rule out weirdness in the child theme - menu still broken.
  4. Installing a copy of the site on my localhost and testing it there, the menu is also broken on my local MAMP instance.

I can’t think of any other things to try! If you’d like an admin login or any other info, please feel free to contact me and i can set you up.

Thank you!

Good morning

I cant see your website:

Your access to this site has been limited
Your access to this service has been temporarily limited. Please try again in a few minutes. (HTTP response code 503)

Reason: Access from your area has been temporarily limited for security reasons.

Make sure you have a correct menu setup in appearance> menu, there must be a child and parent menu setup for sure to have a dropdown function, # sign in the url means you re using custom link menu element


Thanks for your reply. Sorry we had country blocking on in Wordfence, i’ve disabled it temporarily if you’d like to look t the site.

I’ve checked and the dropdown menu item isn’t a custom link, it’s set to a wordpress page, as are all the child menu elements, but for some reason even when i tried deleting and re-creating the link it still shows up as “#” and not the correct URL. When i create a new top level item, the URLS are correct, but as soon as i try adding sub-menu items to it, the url changes to “#”

Any help would be appreciated, thanks! If you’d like an admin login let me know and i can send you a temp user login.

Good morning

I can see this no, but can i check this problem from the backend? please use this plugin to create temporary access for us, its automatic login link and does not requires sharing your admin details. here is How To guide. at the and don’t forget about  “Set as private reply” at the bottom of the message box 

I appear to be experiencing the same problem in Dazzling since WP 5.6.1 https://ballaratdojo.com.au/
Currently I have moved the child items into the main menu to ensure functionality but if a cure was discovered I would like to hear about it. Disabling plugins has no effect but changing themes fixes it.

The problem has been already reported and we just need to wait for the theme update, sorry for this inconvenience