Dazzling menu 2nd and subsequent pages

Using child theme.
Home page menu colors correct, menu is color #333 until you roll over it in which case it turns white with a #007 background. Great. Except on the second and subsequent pages, the menu colors are still #333 even when it is active. I’ve tried many variations of what I have seen here, but I can’t seem to get it.
Site: skiptraces.com
Thank you.
Current iteration of the code is:
.dropdown-menu > .active > a,
.navbar-default .navbar-nav .open .dropdown-menu > .active > a,
.navbar-default .navbar-nav > li> a:hover {
color: #fff;
background-color: #007;

You will notice the footer spacing is different on the first and subsequent pages as well. I don’t know why, but that is a side issue. Menu issue is frustrating.

Thank you, and thank you for a great theme.

Hi there

Hope you are having a good day and thank you for your question :slight_smile:
In order to check your question i need to see your live website, please provide url and i will take a look

I did. https://skiptraces.com/

hey there

Please add this CSS in appearance - customize - additional CSS

.navbar-default .navbar-nav>.active>a, .navbar-default .navbar-nav>.active>a:focus, .navbar-default .navbar-nav>.active>a:hover {
    color: #f7f7f7;

Colorlib Support Team

Thank you! I eventually got this to work, but my first attempt failed. I made the change in my child theme css and used FTP to upload it to the dazzling-child directory. I then cleaned my machine with Ccleaner to get rid of any traces of cookies and Internet cache, and then rebooted, which is what gets rid of the cache files. There was no change. It’s as if the theme was not recognizing the child theme css. I went in and made the change to the additional CSS as you instructed and that did make an immediate difference, but I have since deleted that and uploaded a child theme CSS file which it now “recognizes.”

I hope this is clear – I am stumped as to why the child theme CSS file that I first FTP’d to the site did not immediately reflect the change. But it now does, a couple of days later.

Thank you,

Hi Becky

Well, the reason for this is that you additional css style is on more higher leve than child theme css :slight_smile:
please check this link if you want to know more about cache and how to clear it,

Is there anything else for me?

I again experimented with changing the color to a red and then clearing the browser cache. That did nothing, however, what did work was to use the Flush Cache on the GoDaddy console. There is a little drop down menu that has Account Settings, Flush Cache, FAQ and Support, and so on.

So hereafter when I am working with the CSS would you recommend that I work with the CSS in the Additional Style section before making it permanent in the child theme css file? I appreciate your help in helping me to understand how the files are processed and what goes on and how best to work with it.

Thank you,

Hi Becky,

Yes try and use it in the additional CSS section before moving it to the child theme.