Disable comments

I have turned off comments for my website as seen on this screenshot: ( https://puu.sh/A53y9/d4bd88fee7.png ). Why is there still an option to comment on certain places on my site, such as this? http://ohlala.hr/1-9/

I understand it says “Allow comments for future articles”, but how do I disable the comments for older articles and web pages?

Hello there,

I hope you are doing well today.

Since you have already disabled the comments in the settings, please edit the page then scroll down to the Discussion section and ensure Allow Comments is disabled.

Best Regards,

The page is not showing up in the “pages” menu. How can I edit it?


Try any of the method noted here: http://www.wpbeginner.com/plugins/how-to-turn-off-or-disable-comments-in-wordpress-pages/

Let us know,


Hi there

“The page is not showing up in the “pages” menu. How can I edit it?” - deactivate all your plugins and check again

p.s. Please consider, problems that are not related to the theme and related to WordPress can be fixed much faster and efficiently if you do research in the internet

Thanks that worked.

Hi, there

I will close this case now, Feel free to contact us again if you have other questions Thanks!