Enable Social icons with Wordpress Customizer


As per your theme documentation, you have said that “Social Media Icons can be enabled via Theme Options – Social. Below you will see several, one for each social network. In those fields you should copy/paste URL to your actual social network profile.”

But since there is no Theme Options now, I would like to know how to get those icons. I tried using them in footer widgets by using “Sparkling Social Widget” which gives nothing. Please help!

Thanks in advance.

I have the same problem. Please help !

I have the same problem

Yes, same problem here. They aren’t available in the updated theme.

Bumping. Social Icons are missing after recent update. There’s now way to enable them. Could someone look into this?

Same here guys… SURELY sorting out social sharing is an important factor for us web peeps.
Almost a priority for us and no real answers or even acknowledgement coming from you doesn’t sit too well.

Can we at least have an update of what’s happening

I would like to know about this as well. I have two other sites that are running Sparkling 1.9 (or a child theme based on it), but just started two more that I planned on using Sparkling for, and now with 2.0.1 I see no place to enter the URLs.

Same thing here. Hope to see an update soon.

i have the same problem too, then i install plugin jetpack, you can use widget social media from jetpack.


Hi There,

Thanks for posting here.

In the recent version of Sparkling theme the social icons are handled differently.

To create social icons follow the following steps :

  1. Create a menu like any other menu in the admin area of your site under Appearance -> Menus .
  2. Use the correct urls in the menu items, so for twitter it must be twitter.com for facebook it must be facebook.com. Otherwise URLs won’t get recognized and you will get squares without icons.
  3. Set theme location for this menu as “Social Links”
  4. Then use the Sparkling Social Widget in the sidebar or enable the Footer Social Icons by checking the option on the following path.

Admin Area -> Appearance -> Customize -> Sparkling Options -> Social

Best Regards,

Thanks! I can confirm that it works.

You are most welcome here :slight_smile: