Front page menu color

-I can’t for the life of me figure out how to change the color of the Front Page menu items from white! <insert hair ripping emoji here> I’m referring to the text at the top you click on to link to other pages.

-Also, when I click on one of those links and it takes me to the corresponding page, I can’t figure out how to change the color of the title text for that page. It’s white as well and really hard to see on the background photo I added.


Thanks a million.

Hello there,

I hope you are doing well today.

You can use the following CSS code to change the menu font color by going to Appearance > Customize > Additional CSS and pasting it there.

/*Menu font color*/
#header .top-header .header-navigation ul li a {
    color: red;

Could you please provide a link to your website so that I can inspect the pages?

Best Regards,

My site is I finally figured out how to change the background photo on the front page so the white letters work better now. Is the above text what I would use to change the color of the title font when you get to the 30-Day Budget Builder Challenge page as well as the Video page?

And more questions:
-Since it is a 30 day challenge, I have created 30 individual pages, one for each day’s information. I added a widget to put a sidebar on just those pages and their main page, 30-Day Budget Builder Challenge (you’ll see the sidebar on that page, the others are private since I am not releasing the Challenge until Saturday) to navigate between them all. What I can’t for the life of me figure out how to do is to keep all those pages from showing up in the top navigation menu when I make them public! I can’t have 30 pages up there! I tried to create sub pages for a drop down under the 30-Day Challenge page link up there, but the site doesn’t seem to be equipped for 30 drop down items and it was impossible to scroll beyond number 10. Can you please provide me with guidance on keeping those pages off the top menu but still in the sidebar menu?
-I would also love for people to be able to comment on each day’s challenge, those 30 pages. I have checked the Allow Comments box in each page but when I test publish them there is no comment box shown.

Thank you so much!

I have a screenshot of what it looks like with all those pages listed once published, but it’s too large to attach here - let me know if I can email it to you. Any thoughts on how publish them but not list them in the navigation bar? I’ve got to have the site launch-ready Friday night!


Hello there,

Have you added each of the 30 day challenges as pages or posts?

In order to prevent the posts appearing in the menu, lease go to Appearance > Menu and select the menu that you have assigned to the navigation bar then go to “Menu Settings” and ensure the option “Auto Add Pages” is not checked so it should be disabled then save the menu.

To enable the comments, please go to the WordPress admin panel > Settings > Discussion and enable “Allow people to post comments on new articles” then save the changes.

Best Regards,

I think I have the page menu issue figured out now, but no matter what I check, I cannot get a comment box to appear for any page. Here’s what I’ve done:
-> Settings > Discussion > enable “Allow people to post comments on new articles”
-> chose page (or post) > enable “Allow Comments”

I don’t see any sort of code mentioning “comments” in page.php. I have no idea if it should be in that page, or if it is contained in a widget or somewhere else, but I have no clue why I can’t see a comment box on any page or post on my website with those items above checked.

Did I delete something upon setting up my theme initially that contained the page and post comment location? Would love to have this figured out today, if possible. Thank you!

Hello there,

Illdy theme by design, remove the comments on pages given that people generally disable this on pages.
How ever comments do work on blog posts.
If it is you’d like comments on pages I’ll have to make a request to the development team to have this implemented.

Best Regards.

Ok, thanks. What am I doing wrong if I can’t see a comment box on posts either?

Well, I’ll be - I can see a comment box now with my blog post. If there is any way to copy that code to be used on pages that would be great!

Hello there,

In order to have the comment work on pages, you would have to edit the age then go to Screen Options and enable the comments checkbox.

Best Regards,