How to display full blog post not snippets on blog landing page

Hello: Even though I have my “Reading” settings in the Dashboard set to “For each article in a feed, show full text” not “summary” it still seems to show the “Summary” or a snippet with a “Read More” CFA button at the bottom on the blog landing page instead of the full blog post as I intended.

Note: in my “Reading” settings, I also have my front page for my blog set to “static”.

See the screenshot of my blog landing page as mentioned above.

Can you help me with this? Thank you!

Hi @amoeba12,

I hope you are well today and thank you for your question.

Do not change anything in the setting “For each article in a feed, show” because it’s related with feed and it has nothing to do with blog.

You can try achieving this by using the child theme solution posted in the following topic.

Best Regards,