How to remove copyright information from travelify theme?

You can always find original files on or on Github: Travelify/footer-extensions.php at master · puikinsh/Travelify · GitHub

Hello Aigars,

This theme is wonderful!!

I have a problem with the footer. I put this code (the code you presented earlier) in the functions.php of my child theme:

add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles' );
function theme_enqueue_styles() {
    wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );
    wp_enqueue_style( 'child-style',
        get_stylesheet_directory_uri() . '/style.css',
// Remove navigation link from TinyNav
add_action( 'init' , 'remove_navigation_link' , 10 );
function remove_navigation_link() {
        remove_action( 'wp_nav_menu_items', 'travelify_nav_menu_alter', 10, 2 );



// Replace copyright information from footer-extensions.php

// Remove old copyright text
add_action( 'init' , 'remove_copyright' , 15 );
function remove_copyright() {
        remove_action( 'travelify_footer', 'travelify_footer_info', 30 );

// Add new copyright info
add_action( 'travelify_footer' , 'new_footer_info' , 30 );
function new_footer_info() {
   $output = '<div class="copyright">All rights reserver <a href="" title="BWD">Designed By BWD</a> Theme by <a href="" title="colorlib">colorlib</a></div>';
   echo $output;


The new information shows up in the footer.

But EVERY TIME I make a small change in the copyright info, even when I change a single letter (for example when I change ‘reserver’ to ‘reserved’) I get a blank screen.

Can you please help me find the cause of my problem? It seems as if your code works, but I keep getting blank screens after I make a change to it.

There are no errors in your code and it should works just fine. And it should be possible to change spelling and other things. This is definitely not the case.

Make sure to check your error logo or enable WordPress debug mode by adding this to your wp-config.php file:

define( 'WP_DEBUG', true );

See what these errors are saying and make sure to fix everything accordingly.

Dear Aigars,

Thanks for your quick reply!

I changed DEBUG false to ‘true’ and now errors are showing up.
I still get a blank screen when I put the code above in my functions.php file.

This is what shows up (sorry for some words being in Dutch):

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/vhosts/41/121952/webspace/httpdocs/ on line 3378 Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /var/www/vhosts/41/121952/webspace/httpdocs/ on line 3378 Notice: has_cap werd aangeroepen met een argument dat verouderd is sinds versie2.0! Gebruik van de gebruikerslevels in plug-ins en thema's is niet meer mogelijk. Gebruik in plaats daarvan rollen. in /var/www/vhosts/41/121952/webspace/httpdocs/ on line 3495

It doesn’t seem that the errors are saying anything particular about the functions.php file in my child theme.
Do you know what to do now?

Many thanks!!

  • post deleted -

As you can see from your error code this has nothing to do with code you were using inside Child Theme functions.php

Not sure what causes this but it appears that you are using either completely outdated version of WordPress or some really old and outdated plugins. Another thing might be that you have tried to use wp_register_sidebar_widget which is depreciated.

Hi Aigars,

Thanks again for your time.

I am using the latest version of Wordpress.

I tried deactivating all plugins and activated them 1 by 1. I discovered that it was teh DMS Guestbook plugin and the DMS Guestbook widget that caused the errors to appear.

I deleted those plugins and now there are no errors showing up.

However, I still get blank screens after I add your code to change the footer text.
It’s really strange. The first time I copy your code in my functions.php, the new footer text shows up.
But when I change 1 letter, I get a blank screen.

Thanks for helping me so far. Do you have any more suggestions?

Hello again,

I managed to do it!! Still got a couple of blank screens, but eventually the new code showed up in the footer.

I have 1 more question though. I would like to call the current year in the footer. Right now, my code is as follows:

add_action( 'travelify_footer' , 'new_footer_info' , 30 );
function new_footer_info() {
   $output = '<div class="copyright">copyright &copy <a href="" title="Playtoday, dè specialist in LEGO">Playtoday</a> 2015 - <?php echo date('Y'); ?> | website gemaakt door <a href="" title="maArtenDesign - beter in beeld">maArtenDesign</a> | thema door <a href="" title="colorlib">colorlib</a></div>';
   echo $output;

But when I added the <?php echo date('Y'); ?> I got an error. I used this code on many other websites. Do you know what the correct code should be for this theme?

1 more thing:

Every time I make a change in my style.css and hit ‘Save’, I get a blank screen on the page …/wp-admin/theme-editor.php (no errors).

The strange thing is: I have a second tab open where I preview the front-end of the website and when I refresh that page, it just refreshes with the new info. It doesn’t generate a blank screen.

On the blank screen, I can go back to …/wp-admin and I get redirected to the dashboard. So I can continue working on the website but it’s still a big hassle to get a blank screen every time I make a change to the style.css.

Thanks in advance!!

You had php tags opened and you tried to add another opening and closing tags inside, so it throws errors. For that there is thing called concatenation.

So the function should look like this:

// Add new copyright info
add_action( 'travelify_footer' , 'new_footer_info' , 30 );
function new_footer_info() {
   echo '<div class="copyright">copyright &copy <a href="" title="Playtoday, dè specialist in LEGO">Playtoday</a> 2015 - '.date('Y').' | website gemaakt door <a href="" title="maArtenDesign - beter in beeld">maArtenDesign</a> | thema door <a href="" title="colorlib">colorlib</a></div>';

Not sure what could cause those errors but it is definitely not theme related. It could be cache plugin, it could be your server fault as it can’t handle the load and loosing connection with database. Check server error logs if you can find anything useful. Maybe try to disable all plugins while you are working on the site to see it it helps.

Thank you so much!

I’m a newbe at PHP so this is very valuable info for me.

Thanks also for the other suggestions. I will look into it.
Have a nice day!

Hi Aigars,

Can I bother you again?

All is well now except for the blank screen popping up every time I make a change on a page/plugin/stylesheet. It’s very annoying.

The problem must lie in the functions.php file of my child theme. Because, when I deactivate the file (by renaming it to functionss.php via FTP) the blank screens are not showing up anymore.

Do you have an idea how I can use the functions.php without getting those white screens?

Maybe I should try importing the parent stylesheet with the @import command in style.css?

Hello Aigars,

I removed the child theme stylesheet enquement paragraph from the functions.php file and used the @import command in my stylesheet instead.

The resolved the issue.

I know this effects the loading speed of my page (which I noticed right away) but for the moment I know no other solution.

Hello! How to remove dashed line separating footer and main menu?


This is a rather old thread and already marked as resolved. Please start your own thread and we will help you from there.


I have a problem , i`m trying to change the content of footer but i can’t.
I don-t created a theme-child, and I wanted to ask if footer can be changed without using a child theme.

This modification still works. Thanks!


Please post a new thread on forum and I will help you, don’t reply to old ones because is making the forum very hard to follow.