Images from posts don't show

Good afternoon,

I’m having an issue with my word press site being able to display images that have been posted as posts.

When a post is put up, it shows the image is missing, if you go into the post and then back to the home page it then displays correctly.

Are you able to assist with this?

Hello there,

I hope you are doing well today.

This could be a caching issue.

Please clear your browser cache then use the following plugin to clear your WordPress cache:

Best Regards,

Issue is still present…
have tried with three different browsers (IE, Chrome & Firefox),
cleared the cache, then went through and got super cache working, cleared cache… still not working.

Deactivate all your third-party plugins and deactivate caching feature from your hosting, also if you are using CDN on your website you have to disable it as well,
Theme can’t do such thing, most probably this is not theme and not WordPress issue
Just for testing, can you test different WordPress theme on this problem?

Have deactivated caching… Not using CDN as it is an intranet page. - still not working.

Do you recommend an add-on for user ability to put up user submitted posts?

Please use this plugin to create temporary access for us, its automatic login link and does not requires sharing your admin details. here is How To guide. at the and don’t forget about  “Set as private reply” at the bottom of the message box  

unfortunately, like i said in my previous post, it is an intranet page, its not accessible from out side our local network.


Sorry but in this case, i have no chance to check it? do you plan to make it publish in the internet? this is the thing that needs to be checked properly

As it is an intranet, it is only ever going to be accessible from our local network… it will not be published to the internet.

I don’t know how can i help you in this case :frowning:

would it be possible to go through with a remote session to check out the issue?
team viewer or something like that?

IM not sure if we can set up such meeting, get in touch with your system administrator or you may have web developer i your company team

If we already excluded plugin from this problem then there is nothing but your hosting environment, this is unusual problem i used to search and have not found anything similar, most probable cause is in the server