Issue installing Shapely Companion

After installing the Shapely Theme, I started installing the recommended plugins, one being Shapely Companion.

Upon activating the plugin, I receive this error:

Parse error: syntax error, unexpected '[' in /nas/content/staging/domain/wp-content/plugins/shapely-companion/inc/widgets/widget-home-clients.php on line 84

Any idea what the issue could be? I am running Theme version 1.1.0 and WordPress 4.7.1

Thank you

Hi @ishio,

Could you try to download the new theme from here and tell us if you have the same issue:



I tried with the beta build and still seeing the same error.
Further I changed line 84 and 87 of /var/www/html/wordpress/wp-content/plugins/shapely-companion/inc/widgets/widget-home-clients.php from [’ '] to ’ ', the error disappears but not sure if that’s the fix.
I can still see this msg in error logs-

<blockquote>File does not exist: /var/www/html/wordpress/wp-content/themes/shapely-master/assets/css, referer:</blockquote>

Perhaps it should be looking under plugins directory?(php noob here)

ls /var/www/html/wordpress/wp-content/plugins/shapely-companion/assets/
css  img  js

Can confirm this still does not resolve the issue.

Even re-downloading the plugin caused it to error.

I can get by prolly without the plugin, gotta really look into why it’s recommended, and would really rather not alter the plugin files to adjust that line of code.

@shiva When I downloaded the shapely-master zip, if you follow the directory, you’ll see why there’s an error. In the Theme’s asset folder, there is no CSS folder

Hi @ll,

Could you post those issue directly on github? That could help us a lot.

Thank you for your understanding,


I posted to theme and plugin repo’s: - Theme - Plugin

Hi @ishio,

You’re awesome.

Thank you for your help,