Links in Body Not Working

I have kind of a strange problem. All of the links on my sidebar and top menu are working just great.
But anything that is linked within the Main Body section such as pictures, words, blog posts, links to other pages, etc. are not working. It’s like I can’t even click within the Main Body section. If I try, it puts my curser on the sidebar. It’s almost as if something in the sidebar is overpowering the whole page.

I have no idea why this is happening, because it was not doing this a few days ago.
The reason I think it might becoming from the sidebar, is because if I click on anything in the Body that is lower than where the sidebar reaches, I don’t have any problems at all & all the links work fine.

Any ideas?

I’ve posted the link below so that you guys can take a look at it & let me know if you have any suggestions.
Thank you SO much.

This page is an example as to how you cannot click into the Contact Us Forum area which is in the Body of the page.
http://becomingesther.org/contact-us/

These two images also help to explain the problem.

The first image shows a picture next to the sidebar, therefore the link in it is un-clickable.

The second image shows that if you just scroll down a little bit further, past where the sidebar is, the link in that same exact picture works just fine.

So strange.

Hi @livylynnglittergirl,

I hope you are well today and thank you for your question.

I troubleshooted the issue on your site and found this is happening because of the following custom CSS code you have added in your site so to resolve the issue please remove this custom CSS code from your site.


body.home #page .main-content-inner, 
div#secondary {
    margin: 0 auto;
    float: none;
    width: 100%;
}

Best Regards,
Movin