No Menu showing in Mobile Version


I don’t know if this has been asked before but I am using the Travelify theme and the menu bar on the mobile version of the site is just a band of colour with no way to navigate to any other pages.

An example can be seen at

Can you help at all?


Hello there,

I hope you are doing well today.

I have inspected your website and the issue appears for me also. Could you please disable any third party plugins that you may have active currently and check to see if the issue remains?

Please update me on the results.

Best Regards,


Thanks for getting back to me. I have disabled every plug in and the problem still exists. I have plugins including AutoOptimize and W3 Total Cache.



Thanks for contacting us, could you share your login so I could assist you further.

Share it privately.

Best Regards,

[email protected]


Thanks for getting in touch with us, It seems I have an issue signing in because of a google authenticator.

Is it possible for you to disable it?

Best Regards,

Hi, I don’t have Google Authenticator enabled - I never have done.

Hi there,

Thanks for your reply.

We have found the issue that is responsible for the menu to be removed the site in mobile viewports

The following CSS is being loaded from the Autoptimize plugin:

/* Mobile responsive support */ @media (max-width:767px) { #main-nav ul{ display: none; } }

You may try to unselect the Optimize CSS Code? option from within Autoptimize to see if this will resolve this issue.


Thank you for your help with this.

I tried your suggestion and it didn’t work but I uninstalled the AutoOptimize plugin completely and it now works. Must be a theme conflict.

Just one last thing. Now the menu is showing, how I can specify what is the first menu option shown on the drop down list. It is currently ‘Contact’ which I want to change

Look at to see an example.

Thanks again for helping with this issue.

Hey there,
Hope you’re doing well today

It isn’t possible to change the order with the current mobile menu setup, but here’s a better option:

Download, install and activate the plugin linked below:

After this, go into the Responsive Menu plugin menu from the WordPress Dashboard and follow the settings as shown in the screenshot attached (replace the menu of choice with the one you’re using).

After this, go to the Button tab and change the distance from top to about 60px (or just about enough to have it set properly).

After this, you should be good.

Best Regards,

Fantastic…works a treat. Thanks again for all of your help.