No Post Top Border If No Featured Image

I noticed on the blog page that no top border appears for posts that don’t use a featured image. I’m not sure if I’m missing something, but I would think the default behavior should be to show a full border when no image is used.

In my child theme, in content.php I have wrapped the following…

<a href="<?php the_permalink(); ?>" title="<?php the_title_attribute(); ?>" >
  <?php the_post_thumbnail( 'sparkling-featured', array( 'class' => 'single-featured' )); ?>


<?php if ( has_post_thumbnail() ) : ?>

<?php endif; ?>

I’m not sure why this wouldn’t be done already, unless like I say I’m missing something.

Hi @ryanks,

I hope you are well today and thank you for your question.

Do you mean the featured image on single posts page or posts listing page?

Could you please share the screenshot of the issue so that i c an troubleshoot it?

Kind Regards,


No top-border visible on posts listing page as seen in screenshot. Single post page didn’t have the problem. Screenshot taken in Firefox on Win/7.


Hi @ryanks,

Thanks for explaining the issue.

I could confirm the issue on my test site and notified the theme developer about this so that it will be fixed.

In the meanwhile you can fix it by adding the following CSS code in the Custom CSS option of the latest version of Sparkling theme on the below path.

Admin Area -> Appearance -> Customize -> Sparkling Options -> Other -> Custom CSS

body.archive .post-inner-content, .post-inner-content {
    border-top: 1px solid #dadada;

Best Regards,