Pixova 1.22.1 - Woocommerce Bug with Inventory


I have a bug in inventory management in Woocomerce when the Theme is active. I have tried switching themes to twenty seventeen and the bug disappears.
When an order is placed on an item that has inventory management switched on the stock level should decrease by the amount ordered but it Pixova is live instead the stock level is overwritten with the negative stock amount.

E.g Initial Stock = 100
Order Quantity = 4
If Theme is Twenty Seventeen - New Stock Level = 96
If Theme is Pixova - New Stock Level = -4

I have tried the site with all plugins (except woocommerce) deactivated and it makes no difference, The issue is clearly in the theme somewhere.

Any ideas how to find the bug?

Hey there

You have to give me site access credentials and steps to replicate your problem, if this a bug then i will report it

Admin - https://www.simplychange.com/wp-admin/?wtlwp_token=a641ec719688555ad00b11374810f1a3

Once logged in you will see on the Products Menu a product called Test Product, if you edit the product you can set inventory to 100

https://www.simplychange.com/product/test-event/ Will show the ability to add to basket, do so and complete the order, selecting invoice as you don’t actually want to pay me.

After order the inventory should be 100 minus the quantity you ordered but will actually be negative of the quantity you ordered.

Using the Dashboard - Health Check - Troubleshooting Menu you can switch the Theme just for you. If you switch to Twenty Seventeen and repeat the steps above Woocommerce works corectly.

Hi Noda, were you able to recreate the problem?


Hi there

Sorry for the delay :frowning:
The link is no more active and i can’t check it anymore,
can you please try to activate one of default WordPress theme and check the problem again? not sure if this is a theme problem

Here is an updated login - https://www.simplychange.com/wp-admin/?wtlwp_token=a641ec719688555ad00b11374810f1a3

When I switch to twenty seventeen theme the problems goes away. I am sure this is a theme issue.

Hey guys! Could you solve it? I have the same problem!!!

Thanks in advance,

Hey there

Sorry for the delay, this problem is now reported and you can see the progress here:

Thank you for logging this, how do I find out when it might be fixed as it is a daily problem.

Good morning

Unfortunately i can’t say any estimate time for this problem but you can subscribe to the thread in GitHub to see the progress