Popular posts widget not showing thumbnails

Hi, my site is careersidekick.com

I have the popular posts widget in the footer area. When the site first loads, it shows the 3 thumbnail images but if you click one of them and go to the next page… or if you just load a different page on your own and then scroll back down, the images don’t show.

I’ve tried different browsers, browsing incognito, etc. Can’t seem to fix it or figure out what’s going on.

Hi @ronnie55,

I hope you are well today and thank you for your question.

I visited your shared site and it seems this is happening because of the custom CSS added on your site.

You can try resolving this issue by adding the following CSS code in the Custom CSS option of your theme on the below path.

Admin Area -> Appearance -> Customize -> Dazzling Options -> Other -> Custom CSS

#popular-posts .wp-post-image {
    display: block;

Best Regards,

Hey Movin,

Thanks for your time and help! I think the issue is still occuring.
I found the custom CSS you mentioned I think. I had added this a while ago:
.single .wp-post-image { display: none; }

My intention was to stop the featured image from displaying before the post up top. Maybe there’s a more elegant way of doing that? a way that won’t disrupt the popular posts widget?

If not, no big deal. I can use a different widget. I just wanted to follow up and see if there’s an easy solution I am overlooking. Because I’m not a programmer, I really don’t know what I’m doing with CSS other than the basics.

Ooh I think I fixed it. I changed my old custom CSS to this:

.entry-header .wp-post-image { display: none; }

Am I overlooking anything here or is this a good solution for removing featured image from displaying on top of single posts?

Please use the following CSS code to hide the featured image.

body.single-post .entry-header img.thumbnail {
    display: none;

The above CSS won’t apply on any other images than the featured image on single post.