Portfolio short code page displaying wrong

Shapely is a great theme thanks!
I have only one issue which I cannot solve.
I have searched forums for a solution and whilst their are many with similar problems I have yet to find a solution that works.

The issue:
I have 12 images appearing in the home page portfolio widget which displays and works correctly. I have used a short code link - portfolio - in a link within a post and this opens the portfolio page. However, only 7 images appear in the widget at the top of the page and immediately below these are 5 posts. These 5 posts are the ones missing from above.
When I scroll the page the URL changes to portfolio/page/2/

So my questions are:

  • why are only 7 appearing and not 12?
  • what is the logic behind having page 2 appear under the thumbnails?

I have installed the custom plugin colorlib-divilab-plugin-11
I also changed the code (around line 40) of files,
‘posts_per_page’ => 12,`



Can you try this answer: https://colorlibsupport.com/t/shapely-portfolio-needs-more-than-10-items/#post-116531

If that didn’t work, can you show the URL that has this issue?

Let us know,


Hi Laranz,
Thanks for your response on this issue.
The above link describes what I have already done. The home page widget does in fact work as I want it to. It is the portfolio page which is displaying incorrectly (only seven projects).
If I cannot solve it then I would prefer to have a work around where this does not appear at all when using this link:
At present this page is not linked directly from within the site, only if one knows the URL.
I have disabled the widget appearing at the top of the portfolio page so that only the projects themselves appear on the scrolling page(s).
By navigating within the site this is how the page appears:

Thanks again!


Sorry for a late in response. You can change the number 7 in Settings -> Readings or Settings -> Writing.

This https://web.alexrowbotham.com/portfolio or Projects Archive | freelance web design will be the portfolio page URL, you’re using any plugin like for load more or some sort? so that when you scroll it gives you second page? I think that cause the issue. Try disable it and check that solves the issue. Or try disable all the plugins except the theme’s recommended one and see that fixes the issue.

Please update us.

Let us know,