ReCaptcha option in Contact Form 7 not displaying on mobile

Hey guys, sorry to bother you with this but I’ve tried posting on the WP support for Contact form 7 and the Google ReCaptcha group to no avail.

I’m using Contact form 7 across my site, mainly on my enquiries and contact pages. I’ve integrated the ReCaptcha plug in and entered all my details correctly. It shows up fine on my laptop, however testing it on mobile- it doesn’t load at all and subsequently the form can’t be submitted. Also, a few other laptops I’ve used to test it, also saw the same problem. The text fields are all fine.

I’m using v2, can you please help me?

Hello there,

I hope you are doing well today.

What mobile devices did you use to test this?

Best Regards,
Support

Hey there

I’m great thanks and you?

I used an iPhone and two Androids (Samsung and Xiaomi)- so Safari, Chrome and UC Browser. It didn’t show up on any of them.

The other laptops that had the problem were using Chrome.

Hi there

I need to see your live website, please provide url and i will take a look

Hey!

Sure, no problem. My website is https://www.cupcakeconnection.co.za.

Thanks so much

Good evening

Sorry but i cant see any captcha on your contact form:
https://cupcakeconnection.co.za/contact/

Please tell me where can i see it

Good Evening Noda

Ohhh noo! See, that’s the problem. It’s supposed to be there- under authentication :frowning:

I’ve attached a screenshot of what it looks like on my laptop browser.

HI

Please see attached screenshot, it is not visible and it is not visible even in a markup of the page

Good morning Noda

I fixed it. I uninstalled and reinstalled CF7 for the fifth time, cleaned up some plugins and now it looks like it’s finally working!

Have a look: https://www.cupcakeconnection.co.za/contact/

Or I’m not sure if you did anything? But it finally seems to be working as it should now.

Thank you so much for all the help!

While I’ve got you here, the display of the WooCommerce ‘Cart/Basket’ page seems so cluttered- there are things not aligned properly on mobile, is there anything I can do about that? On desktop it’s fine. Also, the checkbox for the terms and conditions on the Checkout page sits over the text on mobile- any solution?

HI there

  1. Captcha - it works well me, the functionality of captcha is normal in my case, try this, please activate one of default WordPress theme and let me know if you have the same problem, we must identify is this a theme related issue or not
  2. can you show this problem on the screenshot?

Hey there!

Sorry for the delayed response.

The writing is fine with the WordPress Twenty Seventeen Theme. So maybe its Shapely?

Please see screenshot attached.

hey there

Please add this CSS in appearance - customize - additional CSS

.woocommerce-page form .form-row label.checkbox span {
top: -10px;
left: 18px;
position: relative;
}

Thanks!
Colorlib Support Team

Hi there!

Worked like a charm :slight_smile:

Thanks so much for all your help!

Hope you have a lovely day :slight_smile:

You are welcome Roch :slight_smile:

Let me know if you have questions in the new ticket, i will close this

If you’re happy with our service, don’t forget to rate us: [Shapely] Reviews | WordPress.org