Remove comments, author, date?

How to remove the comments, author and date on all pages but am only using this for portfolio pages.

Also, how do I make the portfolio gallery pages full screen?

Hi @kieranp,

I hope you are well today and thanks for posting here.

I can see you have marked this topic as resolved so just want to know whether you have resolved it?

Best Regards,

Hi Movin,
I’ve managed to get rid of the comments, date and author however I still can’t figure out how to make my galleries full screen as I mentioned in my follow up comment. I mean full screen in the sense of the galleries fitting the entire width of the page.
Thanks alot!

Could you please share me the page URL from your site where the gallery is displaying so that i can troubleshoot it?

Isn’t as wide as

For example.

It seems you have set layout of that portfolio page to No sidebar instead you should set it to Full Width as shown in the attached screenshot.

Alternatively you can try making it full width by adding the following CSS code in the Custom CSS option of your theme on the below path.

Admin Area -> Appearance -> Customize -> Shapely Options -> Other

.single-jetpack-portfolio.has-no-sidebar div#primary {
    width: 100%;

Brilliant, thanks

On the same subject - How did you manage to remove the Author info from the Mobile versions? I have removed them from desktop views but not mobile…


Think its this piece of code added to the Custom CSS under Shapely Options under Appearance-> Customise.

body.single-jetpack-portfolio .author-bio {
display: none;

@kieranp You are most welcome here :slight_smile:

Thank you for the reply but the following did not work.

.body.single-jetpack-portfolio .author-bio {
display: none;

I presume you have jetpack installed?
You could also try adding:

.post-meta {
display: none;

Under the first piece of CSS.

I already have the following in my custom css.

.post-meta {
display: none;

Does not show on wide desktop view but shows up when I narrow the page up. - My test site

@martinjd Please try using below custom CSS code.

body.single-jetpack-portfolio .author-bio {
display: none;

Thank you for reply - but still no joy!

OK I fixed it - Did not realize I had to post the code directly in to Jet Pack Style Sheet. I was actually putting the code in the Theme Custom Style Sheet…

Working now.

Thank you

@martinjd You are most welcome here :slight_smile: