Removing Featured Image from Homepage


I would like to add a featured image to my post so an image appears Sparkling Popular Posts widget but I don’t want it appearing on the main website/post.

How can I stop it appearing? I currently have slider turned off but if I select a featured image it appears at the top of the page.


This line of code is responsible for featured images in single posts view and blog. To remove images from blog page you should edit this line from content.php file and for single post view you should remove this line from content-single.php

<?php the_post_thumbnail( 'sparkling-featured', array( 'class' => 'single-featured' )); ?>

These changes can be done via Child Theme by copy-pasting content-single.php and content.php to Child Theme and then you can edit those newly created files on Child Theme folder.

Alternatively you can simply add this code to Theme Options - Other - Custom CSS and featured images will be hidden but still loaded. So this might slightly affect website performance as it would appear that images are there but not visible for user.

.single-featured {
  display: none;

Let me know if this helps.

Awesome, that worked thank you! :slight_smile: