Right hand widgets

Hi,

Most of my widgets have disappeared from the hand side. The first one is showing but the others (social media, follow me, search etc) are not there?

Also I have added a footer (just with copyright text) but that is also not showing… can you help?

Thanks

Hi @mandyd,

Sorry to hear of the problem you are having.

Can you please try temporary enabling WP_DEBUG mode? To do this, just go to wp-config.php include this:

define('WP_DEBUG',true);

You might already have a line for WP_DEBUG, so just make sure it’s set to true.

Let me know what errors if any you are getting so that i can troubleshoot it.

Kind Regards,
Movin

Hi Movin,

Thanks for you reply. i do not have that line in the wp-config.php file. Whereabouts should it go?

Thanks
Mandy

Hi Mandy,

If you have set the WP debug to true then we should get some errors or messages related to the issue on your site but i visited your site and didn’t get anything.

Could you please try temporary removing the widgets one by one from your sidebar widget area to find out what is causing the issue?

Have you made any changes in the theme files?

Also this can be due to plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Regards,
Movin

I haven’t set the debug to true as that line doesn’t appear at all. Should I add it?And if so whereabouts?

Thanks

The only change to the theme I have made is removing the search function from the header…

I haven’t set the debug to true as that line doesn’t appear at all. Should I add it?And if so whereabouts?

You should add that line in your WordPress install file wp-config.php as described here http://codex.wordpress.org/WP_DEBUG

The only change to the theme I have made is removing the search function from the header…

So could you please try temporary removing that change by taking backup of your theme first.

I dont seem to have a wp-config.php file at all?!

It’s the mandatory file that every WordPress install requires which you will find in your WordPress directory where wp-content directory is saved.

Find more information about the file on the following pages.

http://premium.wpmudev.org/manuals/wpmu-manual-2/creating-and-editing-your-wp-config-php-file/

Have you tried temporary removing the changes that you have made in the theme files and checked plugin conflict as described previously?

Hi

I have undone the change I made to the header but I cant find out to edit the wp-config file. I cant find cPanel?

Thanks
mandy

You will get your cPanel or FTP details from your web host so please contact them.

Could you please also share me your site login details privately by checking the option “Set as private reply” when replying so that i can directly troubleshoot the issue on your site?

Hi

Details are…
URL : http://www.motherofgoodintentions.co.uk
Admin URL : http://www.motherofgoodintentions.co.uk/wp-admin/
Admin Username : 387hastg
Admin Password : dEhctNGEbhi8

Thank you!
Mandy

Hi

Sorry, I just wondered if you’d had any success?

Thanks

Hi Movin

Did you get my private replies?

Thanks
Mandy

Hi Mandy,

Thank you for your patience here.

Yes i got your site details in your private reply.

I checked your site and now all the widgets are displaying fine on it as shown in the attached screenshot.

Have you managed to make it work?

Please advise.

Regards,
Movin

Hi,

Yes I got them working again last night thanks!

How do I get the follow me icons to look like the ones in the demo (or my own design) rather than the default ones?

Thanks
Mandy