Shapely not displaying properly in Chrome, Safari, & Internet Explorer

Hi! I’m in LOVE with the Shapely theme and love my new website. Eager to show it off, I asked a bunch of friends to check out my site and make sure everything was working properly. Apparently the site isn’t displaying properly in Chrome, Safari, or Internet Explorer. Some people had better luck when they revisited the website later, but most people using these browsers said it was very strange to look at and there was a lot of white text on a white background (which means my images aren’t displaying). In fact, Firefox is the only browser that seems to be displaying it properly.

My friends were kind enough to get screenshots of what my site looks like on their browsers, and I’ve attached those here. The site is

Thank you!

I have the same problem. Please help us!
The website is:
Thank you.

Hello?? Support, please help. It’s been MONTHS of my site not displaying properly!

Hi @rairose and @roxana11,

I am very sorry about our delay in reply, I apologies for that first.

It seems you have enabled Jetpack’s Mobile theme, so only it displayed like that, To disable that go to Jetpack -> Settings -> Writing tab and scroll down to the Theme Enhancements and the “Enable the Jetpack Mobile theme” option and turn that off.

Let us know,


Ahh! Laranz, thank you SOOOO much! That did it! It’s perfect! Thank you thank you thank you!

I can’t believe it was such a simple fix. Thank you so much!



Glad we helped. :slight_smile: The website is wonderful. :slight_smile:

Let us know If you have any other questions. Please feel free to contact us again in the future regarding any other issues.

If you’re happy with our service, don’t forget to rate us: [Shapely] Reviews |


Hi Laranz,

Thank you so much for your help! Now that it’s displaying properly, I tried it out on Firefox and Chrome on a Mac and IE on a PC. On Internet Explorer on a PC, my top picture isn’t loading and none of the icons are showing up (including the down-arrow in the menu beside “Services,” the search magnifying glass, or any of my social media buttons.

They appear on my iMac in Chrome and Firefox, though. Do you know what might be causing this problem?


Hi Rai,

Sorry for a late in response, can you tell us which version of IE you’re testing? Can you test our demo in the same IE? and see that any icons and the top image displaying?

Let us know,