Shapely Video section

I’m trying to use a video directly from file on the front page. The Video section widget has a “video URL” section with a placeholder option. Selecting the URL simple sends you to the media library, rather than giving you the option of inputing a URL? (Obviously the media library is restricted to 20mb!).
The placeholder doesn’t appear either, so I presume this function simply isn’t working??

Hey there,

I hope you are well today and thank you for your question.

I was able to replicate the issue.
I’ll bring this to the attention of the developer.
I suggest uploading the video you to Youtube and using that method instead until the issue is resolved.

Best regards,

Many thanks.

Yes I’ve looked art using Vimeo, but it doesn’t give you full control over how it looks or functions. If I can address a file directly it gives me full control, both artistically and functionally, helping me to integrate it into the site.

I’m afraid I hate putting in youtube videos. I like video to be as integrated into the website as photos/picture are, i.e. part of the design, not an add-on! :-))


Also, if I do use Vimeo and Youtube, they have their own video controls, and there’s no way of turning off the widget video controls which just look odd sat on the lefthand side??

Hi Mike

So far this is what we got on the table if the file upload limit is a problem for you this can be solved by tweaking WordPress, check this link:

Please note, youtube has several advantages and one of them is speed :wink:

Many thanks, I may look for another widget as I want to customise things. Particularly as the Shapely front page is scroll down, I only want the video to autoplay when it’s on screen. Otherwise it’s odd that the sound is playing but you can’t see any video.

Ok, mike let me know if something is needed from us, otherwise i will close this case here

Just a quick last thing. Why don’t the Vimeo video controls work? The viewer is more likely to use those that your on the side of the page? Have they been disabled?

Something to do with position:absolute on the play/pause buttons. I’ve changed it to relative and the vimeo buttons now wrk. I presume the absolute move was putting the vimeo button in a different screen position than was shown on screen?

Hi Mike

Can you show me it I action?
please provide URL of the page and i will take a look at that

I’ve just updated to the new version. The Vimeo controls are now not functioning at all?

Whilst yes there are the Shapely buttons, visitors are going to go for the Vimeo ones first if they are visable?

Also have an extra height logo/menu bar on my tablet?

On the iPhone, still got the large white space between parallax sections.

Good evening Mike

sorry but my question stays same :frowning: i need to see it live, please provide url to the page and i will check whats going on


Video is a scroll down

Hey there

Please use this CSS to hide Vimeo controls in appearance > customize > additional css

.vp-player-inner .controls-wrapper {
    display: none;

Let me know if this worked

Regarding extra space, could you drop one screenshot of this issue?

Regards Noda

The code doesn’t seem to change anything.
Attached is a screen grab. On the main site the text is just under the video.

I’ve now replaced the parallax video section with direct code.

Still have large gaps between widget though on the iPhone


Hey there

i hope you are doing well today

Sorry, i believe this code will fix your problem about white space:

.home iframe {
height: auto !important;
margin: 50px 0px !important;
.home .player .vp-player-layout {
left: 0px !important;
right: 0px !important;

Please add them and let me check it again