Static Front Page

Hi there,

I have a question that is, embarrassingly basic: How do I set up a static front page, like the demo?

I’ve created a home page and a blog page (to show the posts), but when I select the Static Front Page option, I get a blank page. Usually, there is a template for the front page, but I don’t see one with this theme. How can I get 3 posts (excerpts) to appear on the front page?

You can see my page here:

I thought that maybe I need to make the posts that I want to appear on the front page sticky, so I did so and that didn’t help either. Do I need to add widgets to the HomePage widgets? If so, which ones do I need to add?

Any help you can provide is much appreciated!


Theme demo uses blog page for front page and that is not a static page at all.

To actually use static page you need to choose page a page that you want to display on front page.

The process is simple. Go to Settings - Reading - enable “A static page (select below)” and then select page you want to use for front page and for “Posts page:” select your blog page.

Home widgets will be visible only if you are using Static page and not blog psts in front.

Ah, got it. I will stick with a blog page.

Many thanks for your help!


Hi there

First let me say what a pleasure it is to work in the sparkling theme. It plays well with other plugins and is more flexible than anything I have used to date… so Thank you for providing it.

On the topic of static front page, I am looking for a way to have nothing displayed… no posts, and not static front page. Just a slider that I have placed into the Call to action bar. Do you know of a way I can accomplish this? I already have the slider set up…just need to remove the content below it up to the footer

Thanks in advance for your assistance.


Hey @robbieb,

I hope you are well today and thank you for your question.

You can try achieving this by adding the following CSS code in the Custom CSS option of your theme on the below path.

Admin Area -> Appearance -> Customize -> Additional CSS

/*remove content*/
.home .container.main-content-area {
    display: none;

Best Regards,

Worked like a charm! Thank you so very much!


You are most welcome here :slight_smile: