Super slow - loading time problem

Hi guys,

I just set up one page on Illdy theme, and looks great, but the loading time is terrible! The page is loading like 20-30s sometimes. :o

This is not the hosting fault (there are others site there and working pretty fast). Also I add the cache plugin to the site, optimized the images… and still it is slow… or just take a look, site here and it’s super slow (and I didn’t even started adding the content, there is only few basic information there).

Any ideas how to improve it?

Hey there

“20-30s” - really? it loading lighting fast for me :slight_smile: less than 1-2 second, please check it properly :slight_smile: your site is amaingly fast

regards Noda

Hello there,

Please try clearing your browser cache because this may the cause of the slow downs.

Best Regards,

Hi all,
Noticed the same, but only on mobile though!
Seems to be working fine on desktop, haven’t tested tablet yet, but mobile is INCREDIBLY slow loading.

Considering the amount of users visiting websites from their phone this is a major issue and I am extremely disappointed! Anything you guys at colorlib can do to fix this please? Just the mobile loading time though, please?
Tried clearing cache before you ask (Safari, trying to access from iPhone). Tried deactivating the Illdy companion, worked much quicker, so it’s definitely the companion plugins fault.

Hi there

No difference, there is no difference for me on mobile devices and even theoretically there no difference here, the website will load exact same amount of date (or less) for mobile devices, so if you are using same internet connection for your mobile device or desktop site will work the same way, i can recommend this topic for speeding up your site little bit.
One thing, try to disable loader percentage, maybe you are seeing this loaded for a longer time on a mobile device?

Hi Team,

This is my site,

Illdy theme is the best theme but loading time of my site is very slow around for Chrome 4.29 Sec and Firefox its 9.06 sec. Can you please give a solution on it. Due to this I am losing 25% visitors.

I have cleared cache, images size reduced but no use of it.

Kindly give a solution on it.

Hello there,

When it comes to speed there are a few things you can do to speed up the site.

  1. Deactivate and remove any plugin that are not doing anything.
  2. Try using this plugin to optimize the images:
    Smush – Lazy Load Images, Optimize & Compress Images – WordPress plugin |

Here is an article with more information:

Best Regards,

I have done all these thing still site is taking 4 sec to load. What can I do?

Hello there,

Please go to Appearance > Customize > General Options > Preloader and disable the Preloader.

Once you have done that, please try disabling any third party plugins that were not bundled with the theme as one of them may be causing the slowdown.

Best Regards,


I have used the Illdy theme on WP and since I have started the setup, I have faced the same issue. Sometimes the page loads immediately and sometimes the page takes very long to load (different duration every time). But if I cancel the loading (by pressing Esc) and then reload the page, it loads immediately again.

As per Support’s suggestion above, I also disabled the preloader and then even cleared browsing data and cache. I still face the same issue. My site is thankfully still in a demo / testing phase, but once we go live, it will surely effect how quickly a visitor leaves the site and closes the browser.

It would be greatly appreciated if you could figure out what this issue is and get it resolved. It will solve a lot of people’s problem.

Best Regards,

Hello there,

I am thinking that this can be related to the PHP version on the server.

Please try using the following plugin to check the PHP version:

It should be above 7.0.

Best Regards,

Hello Support,

I checked the PHP version and its 5.6.31. I guess that could be the reason. I will get in touch with the hosting provider to see if I can get that upgraded for my account. Once that is done, I will update here if the problem was resolved.

Thank you for your efforts.

Best Regards,

let us know if your problem is resolved

Hello Support,

Our hosting service provider says they cannot upgrade to PHP version 7.0 right now. Therefore we had to deal with the situation a bit differently, which might not be the best of solutions, but for now it was the best solution I could find. Posting it here so it might help others as well.

I added a JavaScript to reload a page once more when it initially loads. This solved the problem, as I mentioned in my first comment in this forum that if I reload the page, it loads immediately.

The Code: (References of posts where I found this solution at the end of this comment).
// Reloading every page to avoid the loading delay
function my_custom_js() {
echo ‘<script type=“text/javascript”>(function(){if(window.localStorage){if(!localStorage.getItem(“firstLoad”)){localStorage[“firstLoad”]=true;window.location.reload();}else{localStorage.removeItem(“firstLoad”);}}})();</script>’;
// Add hook for admin <head></head>
add_action(‘admin_head’, ‘my_custom_js’);
// Add hook for front-end <head></head>
add_action(‘wp_head’, ‘my_custom_js’);

For now I have added the JavaScript from the functions.php page, but I will be changing it to be added as a plugin where I can add all my custom JS & CSS to the site. That way, I don’t have to update the functions.php file every time the theme is updated.


Hi there,
Thanks for sharing the fix.
In this case, please feel to reach out once again in case you encounter any other issues.

Best Regards,