Testimonials not showing up

I followed along exactly in the tutorial, but still can’t get the testimonials to work.

What am I doing wrong?


My posts to the testimonials never publish. They always are in draft mode. I can’t figure out how to get them to publish.


As a conclusion from this thread, there might be some plugin incompatibilities:

Have you followed the steps from here, enabling testimonials in JetPack with no success?

Let me know if you managed to get them alright.


Unfortunately that doesn’t help because I tried deactivating all plugins, except jetpack, and it still doesn’t work. I feel like mine is a separate issue because the testimonials aren’t publishing, they are just stuck in draft mode.

Hello Mike,

Is it possible to provide me temporary admin dashboard access to have a look for myself?
It’s the first time I see this issue and I cannot replicate it on my environment.


PS: If access is possible, don’t forget to mark the private message.

Here is an account you can use (just please don’t screw me over here)

username: tempadmin
password: 3B#61Z39i#uXMfHiTpWRdv4D

Hello Mike,

First of all, I have no interest in screwing you over, only to fix the problem in the shortest time :slight_smile:

Quite a strange issue, didn’t saw it before.

From my research it seems like there might be a JetPack internal conflict, and based on this support thread from their forum I kindly ask you to disable all the modules except the Testimonial one and try to publish again.

If this will not fix the issue, please disable all the plugins you installed and try again.

Additional, I see that you have some warnings in the dashboard, so please contact your hosting provider and ask them to disable the PHP warnings.

If nothing from the above works, I’ll have another look and search for additional debugging measures.

Let me know if you managed to get it fixed!

PS: I don’t want to break anything on the website, that’s why I won’t do the above myself.