The Magic Method Related Post error

I keep getting this error

Warning: The magic method Shapely_Related_Posts::__wakeup() must have public visibility in /usr/home/kkast/domains/ on line 89

It’s affecting my my audio igniter on my site and won’t let it load could we get a quick fix!! I did recently update super video Player but that didn’t seem to cause the issue my site is keebu dot com

I included a screenshot

Hey there

What is the version of PHP on your website?
Could you please provide access credentials privately?


We’re using PHP version 8.2 I think dm is on the way

dm sent has been sent let me know when you get to it!!

Hi there

Could you kindly lower your PHP version to either 8.0 or 7.4? Kindly inform me of the outcome.

Best regards.

It’s already set at 8.1


Yes, I understand, but for testing purposes, can you please temporarily switch to PHP 7.4 and then switch back again?


Guys I haven’t responded because we’re trying to move host!!

Hi there.

okay, let me know if any assistance is required from our side


I went from 8.2 to 7.4 and saw no difference then went back from 7.4 to 8.2

but when we went from 8.1 to 8.2 we saw a difference the website working more as it suppose to

Hey there

So, you are confirming that 8.1 works better than 8.2 or 7.4 version?


8.2 worked better the error seemed to disappear for a while however the error has returned

Warning: The magic method Shapely_Related_Posts::__wakeup() must have public visibility in /usr/home/kkast/domains/ on line 89

1 Like

Hi there

Sorry about that, you can disable that warning by following this documentation: How to Turn Off PHP Errors in WordPress

​Let me know if you need further assistance, we are happy to help!


Hi all!

I have the same problem too. I did all the recommendations written above, but it didn’t help.
According to the latest recommendation, I made changes to wp-config.php
ini_set(‘display_errors’, ‘Off’);
ini_set(‘error_reporting’, E_ALL);
define( ‘WP_DEBUG’ , false);
define( ‘WP_DEBUG_DISPLAY’ , false);`

After this, the error does not show in the admin panel, but it remains on the main page of the site.

Perhaps there are still options to fix this?

Hi there

@incap May I take a closer look? can you please provide URL of the page?