Title in header not removing

Hello, I changed the option to remove the title in the header but it still shows up. Is there something I am doing wrong or is this option a bug in the theme? I uploaded a couple of screenshots showing the issue. The first is the option to not show the title in the header, the second is the title still showing, and it shows on every page as well.

Hey there,

I hope you are well today and thank you for your question.

I think you attached the wrong screenshot.
However, the setting does work.
As a troubleshooting step:

  • Check your theme is up to date, version 1.2
  • Ensure the shapely companion plugin is installed and activated.

Also please note those settings only affect the single blog post.

Best regards,

Hello, thank you for your response.
I do have the latest version of Shapely installed, and the latest Shapely companion. I am wondering if another setting is needed. I attached the other header options and if I turn both off the header photo disappears.
Question - is there a line in the header.php or another file that I could just simply comment out as a workaround?

Does anyone have any idea on what line of php in what file I would need to comment out to remove the title in the header? Thanks.

Hello there,

We could use some CSS to remove the text. The text in the image seems to be on the hero image so please try using this CSS code by going to Appearance > Customize > Additional CSS and pasting it there.

.image-bg h1 { display: none; }

If this does not work then please provide a link to your website so that I can inspect it.

Best Regards,

Hello again,

Well, that works, but it removes the title from all the pages. Is there some specific CSS that could remove on just a single page?

If this is not feasible then please let me know. I will most likely switching to one of your premium themes in the near future, but it would be nice to get this to work.

This is a new site is running only locally at the moment, so I don’t have it running on the Internet yet.

Thanks again,

Hello there,

You can have the CSS affect specific pages using the page ID. You need to edit the page and look in the URL for the page ID.

How to find the page ID:

Remove the previous CSS and use this instead but replace the page ID with the one for the page you want the code to affect.

.page-id-111 .image-bg h1 { display: none; }

Best Regards,

Hello again,

I tried the changes and I can get this to work with the home display page, but not the other pages. I don’t know why at this point, but a plugin might be affecting the results.

Anyway, I will experiment more with the CSS options, and so at this point I will eventually upgrade to the Hatch premium template for use in production, so perhaps I will have more control, or different layout going forward.

Thank you,