Translation problem


I use Illdy theme. I am translating as described (link).

I can translate for example ‘Comments are off for this post’,
but I can’t translate ‘search’ – I didn’t see it in pot file
and I can’t translate ‘Read More’ – I see it in illdy.pot but if I change this text and save po file there is no change on my website.

For ‘Comments are off for this post’ there is no problem. I translated it, save it in the same po file and I see the change on my website.

I have my page local, using with XAMPP.

Hello @marcinph,

I need to have a closer investigation of this issue and if there’s indeed some text strings missing we’ll include them in the upcoming theme update.

Sorry for the trouble!


Thank you!
If you need any support by my side, please let me know.

Thank you for understanding!

If you can provide a couple of screenshots of where is the text that you cannot translate, that would be absolutely great!


On the red.


I see that all the homepage is in english, so can you please let me know what steps have you did until now towards the translation?

The read more text is already in languages > illdy.pot file, so you can already deal with via that file.

The search box should be automatic translated because as far as I can tell that widget is coming from the default wordpress files and the translate plugin should deal with it automatically.

Now, for the dinamic fields from customizer, there are 2 ways to deal with them.
First you fill the content and generate a new .pot file that includes that text string and you translate it there, or you use a plugin like qTranslate X that offers a custom field shortcode to deal with multiple languages: [:en]English Text[:de]Deutsch[:]

Let me know if the above got you forward with the setup.


Now is correct.

I deleted all the Illdy .pot .po and .mo files from server.
Then I uploaded Illdy.pot once again.
I installed Loco Translate plugin and now if I change ‘Read More’ and ‘Search’ I see it changed on my site.

I uninstalled Wp Fastest Cache plugin too.

But I don’t know where was the problem. First I set my native language in Wordpress settings. Then
I translated with PoEdit or Loco Translate, but there was any change on my homepage. The text like ‘Search’ hadn’t translated automatically.

Thanks for the support!

That’s such great news and feedback, I’m very happy you got it fixed.

Thank you for the heads-up!

Enjoy the rest of the week.

Another way to it. I use polylang functions.

You have to modify functions.php and each php where you want to translate.

For example, change “Contact-us” section title:
-> functions.php
pll_register_string( ‘Contact-us’, get_theme_mod( ‘illdy_contact_us_general_title’, __( ‘Contact us’, ‘illdy’ ) ), ‘illdy’ );’

<?php if( $general_title ): ?>
  <div class="col-sm-12">
	 <h3><?php echo illdy_sanitize_html( pll_e( $general_title ) ); ?></h3>
<?php endif; ?>

Hope it’s help you.
My web: to check it

Once again, thank you @fabe for the valuable knowledge on how to achive the theme translation via PolyLang plugin.


Thanks a lot @Ion for your work. It’s just amazing. :wink:

Thank you! Statements like this makes it even better :slight_smile:

Hi…I had this working briefly with the illdy theme. I am integrating both English and Mandarin “Simple Chinese”. I am using Polylang for the posts and pages…and it has create dual pages for these and this seems to be working fine. I have implemented the code as you suggested and like I said it was working initially.

I think it broke when I updated the jumbotron from within the theme editor. I am using the illdy.po file and then I save it as zh_CN.po and I use poedit to generate a file and I’ve upgraded them both the server.

I have also created a child theme so that I don’t loose my customizations as I upgrade and update files. I have the languages PO files in the child theme as well as the illdy parent theme.

Any suggestions on why my string replacements with PO are not working all of the sudden? I am spinning my wheels and wasting a lot of time. This is frustrating… :frowning:


You loaded the text domain correctly? load_child_theme_textdomain() | Function | WordPress Developer Resources

If that fails, can you try Loco Translate – WordPress plugin | plugin a go. Take a backup of your translated .po files just in case.

Let us know,


I have the same problem and i tried different things, but i cannot fix it.
My website is

Sorry, I just changed the language settings from ‘Nederlands Formeel’ to “Nederlands” and now is my problem solved. Sorry I bothered.

Okay, thanks for updating us :slight_smile: