Using customized older version and links aren't working on some pcs

Thank you for the theme, I was wondering if I could get some help trying to fix an older version, I understand that since its older no one is obligated to help but it would be greatly appreciated!

Our class blog (60212: INTERACTIVITY & COMPUTATION – CMU School of Art, Fall 2018 • Prof. Golan Levin / TA: Char Stiles) is using version 2.6.6 with some customization by the professor so we can’t update. We have encountered a few students with chrome on windows for whom the links don’t do anything. That is, they click on a link/button/menu item and nothing happens.

I have tried looking for errors in the console, clearing the cache, disabling chrome plugins, updating chrome. Nothing has helped. We suspect it has to do with security issue. The professor has started looking into acquiring an SSL certificate. Do you think that this will solve the problem?

example of one machine that it doesnt work on chrome (it works on other browsers):
Dell Inspiron 15 7000 series
i7 processor 8th gen
windows 10

Hey there

Interesting case, but the thing is that i can’t reproduce this problem on my end, i tried my 3 browser chrome, firefox and opera and everywhere i can click on the links, this is a permanent problem or it happens particular cases?
i really want to replicate problem on my side

For the machines it doesn’t work for it is a permanent problem. Its only a problem on chrome. I haven’t been able to replicate it on any other machine as well. It seems that it is broken for brand new windows machines. Sorry this problem is so hard to replicate!

I thought I would give it a shot to see if it is a known problem or an easy fix, but it seems like that is not the case! Alas! We will simply update & re-do the customization!

Thanks for your time!

Good evening

yes, i can confirm that replicating this problem is not an easy thing, you can see this video from my latest version of Windows 10 and chrome, links are working fine on my end,