WordPress 4.6.1 - Jumbotron not working

Hi, tonight wordpress had an automatic update to 4.6.1 and my website now doesn’t work anymore.
I get this message: Some changes were made in the latest version so that the theme would properly work with core WordPress’ front page system. If you’d like to continue using the custom front page, visit Settings > Readings and set your front page to display a page.

The point is that I was using Jumbotron as homepage, what shall I do now to make it work again???

Hello @svanzy,

This is a little strange since I have tested this myself with the latest version and everything seems to be working the same, as expected.

Can you please provide me website link or screenshots so I can better understand what kind of malfunction you are experiencing?

You might want to have a look here at issue #2 and let me know more about it:


Hi and thank you for your answer, the site is http://www.paoloscotti.net/

I forgot to say that I made a static empty page called “home” but still as you can see I cannot see the old jumbotron image (1900x903) as before

This seems quite strange.

In Dashboard > Appearances > Customize do you see the website alright?

After you created the empty homepage you also need to select it as the static front page in Dashboard > Settings > Reading > Select A Static Page > Select Home

in Dashboard > Appearances > Customize I don’t see the website ok.
and yes I did set the new page as homepage

I have WordPress 4.6.1 - illdy 1.0.29

Another hint: If I fill at least the first word from title in Jumbotron Section it works!

It seems like everything is working and you find yourself in the #2 common issue where you need to add new information for all the section to have it on the live website.

Please confirm that you got everything alright.


Hi Ion and thank you for your answer.

I did set up the info in the reading section as you can see from picture n.1

What is not working for me is the Jumbotron page: if I don’t fill at least one of the fields (I have used a dot as from picture n.2) then the page won’t display properly. Before the update I could leave all the fields blank and the homepage was displayed in full size.



I will start an investigation about this issue and get back to you in the shortest time.

Until further news, please try using a blank character for the field, like   and see if it did the trick.

Additionally, you can use a CSS rule to hide the dot:

.bottom-header.front-page .col-sm-12 { display: none; }

Sorry for the trouble.

Thank you the trick of using   worked fine.

That’s great, I’m happy that you got this as a temporary fix until I conduct all the necessary investigation.

Have a great week!

Nearly all of my front page content was deleted after this update. There is a huge flaw in how your theme updates the front page with how many problems everyone seems to have to have in updating their content. And now having all of this content disappear off of my page, if I wasn’t so invested in this theme already, I would choose another one. Your support, however, is excellent and I do appreciate that. Just please fix this extremely inconveniencing feature.

Edit: The counter, about, and projects widgets aren’t even available to add to the front page anymore.


This seems extremely strange, no content should be deleted and the widgets should just work alright.

Since the theme recently got included in the WP.org public library, everyone will have the option to update the theme version automatically from the dashboard, so some malfunctions might pop-up since we you are not updating the theme progressively, but jumping from versions like 1.14 to 1.29 and this comes with a couple of missing heart beats.

I would love to see more of the issue that you are encountering so maybe you can add me on Skype ( Ion Rutz ) for a screen sharing and a live investigation to get you over it in the shortest time and set up exactly if there’s any issue with the latest updates to be fixed.

Kind regards

Thank you so much we can definitely try a skype screen share. I just added you.

It seems like in the latest Illdy version the widgets had been outsourced to a plugin, Illdy Companion, so in order to use the dedicated widgets that plugin needs to be installed and activated.

Sorry for the trouble so far!

Hi Ion,

FYI I have installed and activated Illdy Companion before starting this post.

Thank you